B2 touch screen stopped working

Posted on
  • The touch screen on my Bangle.js 2 seems to have stopped working. It will turn on, launch the clock, then I can click the button to enter the (default) launcher, but then it doesn't scroll or let me select an app. I've tried reinstalling the default apps and reinstalling the 2v12 firmware.

    Any suggestions for additional troubleshooting? As far as I know, it hasn't received any water or other damage, but maybe it did while I was at the hospital and didn't have it on me.

  • Hi,

    That's an odd one. It is possible that the touchscreen itself got locked up somehow.

    Please could you try connecting with the IDE and pasting the following code in?


    That should turn most of the power-hungry parts of the Bangle on, which will make the battery run down much more quickly (maybe 4 hours or so).

    Please could you leave it to go completely flat and then recharge it? It's possible a full power cycle will sort it out.

  • Thanks for the quick response @Gordon. I entered that "battery drain" code into the IDE and saved it as a *.boot.js file so it would run automatically if I restart the watch. In the console it is repeated returning the following error:

    Uncaught Error: I2C Error: Arbitration (start)

    That did do the trick to drain the battery in about an hour. I recharged it and reinstall the default apps, but the screen still doesn't work like before.

    Yesterday and the day before, before using that "battery drain" code, the battery died before the end of the day on a full overnight charge, even when Bluetooth and/or GadgetBridge were disabled/disconnected, and/or Android integration and Messages apps where uninstalled from the watch.

    Anything else I can try? If this is a hardware issue, how would handle getting it repaired or replaced?

  • Yesterday and the day before, before using that "battery drain" code, the battery died before the end of the day

    Ahh. Have you been swimming with your Bangle or anything like that which would have got it properly wet? That would probably explain the touchscreen, I2C error, and the short battery life.

    Any chance you could take the top strap off the bangle and post up a picture of the hole in the very top? Best if you can try and get it as non-blurry as possible. It's possible yours was one of the Bangles which didn't have a waterproof membrane fitted in which case I'd replace it.

    But yes, if it has just broken through normal use I can sort out a replacement, but if you'd got it properly underwater all I can suggest is you let it run out of battery for a while and then put it on a radiator for a week or so to give it as good a chance of drying out as possible.

  • No, nothing more than washing my hands. I've been very careful with my B2 even though it is waterproof/water-resistant (unlike the B1) since I killed my Matrix PowerWatch 2 which has 200 m Water Resistance by wearing it in a pool for an extended period of time.

    Attached is a close up of the top of the watch with the wrist strap removed. Let me know how you want to proceed with a replacement. Thank you!

    1 Attachment

    • 20220317_094105.jpg
  • Thanks - that definitely looks like it's fine. Can you see a bit of white at the bottom of that hole?

    I'll ask Christine to email you about swapping it for you

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

B2 touch screen stopped working

Posted by Avatar for labarks @labarks