CLI on Mac Monterey won't discover or connect.

Posted on
  • Long story short, I had the CLI running on the previous MacOS version...then after upgrading to Monterey the espurino cli is the only thing that broke. Here's my steps I took to install it on MacOS v11:

    1. Use nvm to make a v8.17.0 environment.
    2. npm i -g node-gyp rebuild
    3. npm i -g espruino
    4. Go to the Security area of the System Preferences. Add Bluetooth permissions to the node version (which node) and the terminal app.
    5. Might take a few espruino --list commands to see the Puck listed with MAC. Can connect from there with the port espruino -p aa-bb-cc-dd-ee-ff

    After upgrading to Monterey, it just never connects and never lists the devices (tried new Pucks too); the Web IDE still works. Only thing I can see in the output that looks suspicious is xpcError: connection invalid when I call espruino -v --list. I made a new nvm environment and tried from scratch...same error. Any thoughts here...I'm not sure where to go next. Full output of the list command attached. Thanks for any pointers.

    1 Attachment

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

CLI on Mac Monterey won't discover or connect.

Posted by Avatar for ayman @ayman