Unable to update AGPS data

Posted on
  • Since updating my Bangle.js 1 to firmware 2v12 I am unable to update the AGPS data. I get an error like "Uncaught SyntaxError: Got [ERASED] expected EOF" or "Uncaught SyntaxError: Got [ERASED] expected ','". Is it a problem with the firmware?

  • Please can you try 'Settings -> utils -> rewrite settings' on the watch? I'm pretty sure it's not a firmware problem - it's more that there's some file on the watch that's got corrupted, but if it happens at reset it could well be the boot0 file which the above option would fix.

  • Unfortunately that hasn't made any difference, also tried reinstalling the firmware. I still get the EOF error or occasionally "Uncaught ReferenceError: \"p\" is not defined" (or \"B\" is not defined).

  • The 2-day update worked fine this morning. No idea what the difference was this time around.

  • Glad it worked! I wonder whether you actually have some app installed that's producing errors and that is throwing things off.

    Might be worth connecting with the Web IDE and flipping between apps to see if errors get displayed.

  • Apropos "The 2-day update". I liked that menu with choice and clear information .
    Is there a reason that those options do not exist for bangle 2?

  • Is there a reason that those options do not exist for bangle 2?

    Yes - we only have one set of data for Bangle.js 2's GPS (it is a different chip and data is provided by a different manufacturer) so we don't get the option

  • Ah, ok, I see. Good reason.
    Do we know the time span the data provides? Stating that could bring back the "clear information" part of the menu.
    (I remember questions and misunderstandings coming up in the forum from time to time)

  • Ahh, I could be wrong here, but I think it was valid for 48 hours

    But yes, that should be mentioned!

  • Uploading AGPS data is still flaky and fails most of the time although I can usually get there eventually. I have tried flipping between the few apps I have installed while connected to the IDE but didn't see any errors. While trying to upload AGPS data just now it showed me a bunch of "OK" lines and then "Uncaught [object Object] at line 1 col 226".

  • Have you got a custom clock face or something like that? If you've got other code on the Bangle that's throwing up errors then they could get seen by the AGPS loader and it'd report them and refuse to do the update

  • Funny you should mention that but I am using Mario Clock. I have discovered that if I go to the menu before attemping the AGPS update, it works reliably - briefly shows me the Bangle splash screen and then "Uploading assistedgps" with a progress bar.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Unable to update AGPS data

Posted by Avatar for skm @skm