• I just received my puck.js. It connected to the IDE which informed me that an upgrade from 2.10 to 2.12 was available so I tried to install it.

    What happened was:

    1. I took out the battery, pressed the button, plugged the battery in, then released the button
    2. The LED went green
    3. I started the Flasher and paired it
    4. The LED went blue and then the progress bar slowly marched to completion
    5. The LED went red. I waited a minute and a half and then reset the puck.js
    6. After a reset, the LED went red again. The puck.js doesn't show up in Bluetooth devices when I start the IDE, but I can repeat the upgrade attempt and get back to the red LED.

    Any ideas on what to try next??

  • That's an odd one - it usually happens when the firmware that's been uploaded isn't working. What was the firmware file you uploaded called?

    And just to check, if you look on the PCB right by where you put the battery in, what version is your Puck?

    Just tried here on a Puck and it seems ok, so it might be worth re-uploading firmware just in case. Also, try applying the battery while holding the button for ~20 seconds, and see if that makes any difference?

  • The Puck version is 2.1a.

    I was using the IDE from Chrome on a Mac as the source - that's where I had the trouble. I had tried flashing it twice.

    Using nRF Toolbox on iOS I was able to reflash it. Now the Puck is visible in the IDE again and I'm off to experimenting.


  • Ok, great! It's tricky - while Web Bluetooth is supposed to be the same on all platforms, it seems the firmware updater in the IDE works fine on some OSes but not on others.

    I have just updated the flashing code so it's possible it'll work better now if you need to try it from the Web IDE in the future.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Puck.js unhappy after upgrade attempt to v2.12 - I need help

Posted by Avatar for NorthVanMarty @NorthVanMarty