[SOLVED] Bangle 2 bricked?

Posted on
  • I bricked my Bangle 2 but still hope there is a way to recover it.

    After updating to 2.12.16 the message displaying didn't work for me so I tried to go back to an earlier version and might have had an update error there.

    That didn't work out and I got an error. I tried down to version 2.10, all the same.
    During the last three days I also tried to get the latest edge builds on in but to no avail.

    I get into the DFU Start without problems and am presented with

    DFU Start

    I then start the flashing operation, wich goes up to 99% and then hangs, with the watch showing

    DFU Start

    After about 30s the watch reboots by itself an the presents the following message


    Is there any way to get another working FW back onto the Bangle 2 or does it need recycling?

    I tried uploading the FW with the IDE Flasher and the nRF Toolbox.

  • there is also "Firmware Update" app in the app loader https://banglejs.com/apps/ , that one may be easier then using DFU. Sadly only next time :-(

    Now you really need nrfconnect or nrf toolbox on the phone and just retry.

  • What device are you using? At some time, I failed similarly with IDE Flasher on Ubuntu, but succeeded on using it on Android.

  • I tried from a Windows 10 PC and an Android 10 mobile.

  • The fact you're still getting the DFU messages seems good - at least the bootloader is ok.

    Maybe try re-downloading and give it another go? Is it possible you uploaded the Bangle.js 1 firmware by accident, rather than the Bangle.js 2 firmware?

    Also if you get 'error', just try redoing the firmware update on your phone. It'll start from where it left off so it might just finish the last 1%

    The "Firmware Update" app in the app loader is the one I'd recommend everyone use now, but it seems it's a bit late for that at this point.

  • I tried about 30-40 times during the last few days, also with different firmwares. Mostly with the edge builds, hoping that the package content would make a difference.

    Just tried again and with the 2.12.28 release it worked.
    I used an Android 10 phone and the nRF Toolbox app.

    Happy to have the little bugger alive again :D

  • Great - glad it's fixed!

    Definitely try and use the Firmware Updater in the App Loader if you can now - it ensures all the firmware is on the watch before doing anything drastic, so it's a lot harder to get into that situation!

  • I just wanted to report that I had a similar issue loading firmware from an Android phone using NRF Connect.

    The process was stalling out and the watch would fall back to trying to reboot. (And failing, which is why I was loading firmware in the first place.)

    I tried over and over again without success.

    Then I guessed that something on the phone wasn't moving quickly enough.

    I rebooted the phone, started NRF Connect as the only app. I didn't bother trying to disable anything from the background, just a normal reboot.

    The NRF Connect firmware update then ran without a hitch.


  • Thanks for the update! That's a strange one - it always amazes me how often the bluetooth stack seems to have issues on laptops and phones. You'd think they would be tested to death.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[SOLVED] Bangle 2 bricked?

Posted by Avatar for msdeibel @msdeibel