Bangle.JS 2 no longer charging

Posted on
  • Hi there!

    I bought a 2-pack of Bangle.JS 2's via the Kickstarter campaign, one of which is totally fine.

    The other one lost its charge fairly quickly - within about 3 to 4 days - which I thought might be due to the Pebble Clock it used, but had similar battery drainage with Anton Clock.

    That was up until a few days ago, when, after running flat, it no longer charges at all. It just stays off when connecting a charger. Even when leaving it connected for a few hours. The charger works fine with the other device.

    When charging via my Linux laptop, I can see system log messages about an unidentified USB device when connecting the working device, but nothing when connecting the other one.

    This device was affected by the contact corrosion issue too. Covering the middle 2 contacts when charging doesn't change anything.

    I would appreciate it if someone could help me identify the issue that keeps the battery dead and prevents charging. Are there any diagnostic tests I can do or steps I could take to get it charging again?

    Thanks in advance!

  • Looks like the same as the Bangle.js 2 can't charge? issue.

  • This device was affected by the contact corrosion issue too.

    Covering the middle 2 contacts stops the corrosion happening in the first place, but it has to effect on charging.

    Please could you post a picture of the contacts? Have you tried cleaning them in any way? If it's not charging I'd say that'd probably be the first thing to try.

    In terms of the battery life, had you tried installing the latest firmware and resetting everything to factory? While you can get 4+ weeks with default settings it's pretty easy to get the battery to run down a lot quicker by installing apps that use the battery more, or changing settings that use the HRM or things like that.

  • Hi Gordon,

    Have you tried cleaning them in any way?

    As you can see from the attached photo, the outer charging contacts don't look dirty at all, but I did wipe it with a dry cloth just in case. No change.

    1 Attachment

    • bjs2-back.jpg
  • Thanks! As you say, those look fine.

    The bootloader on the KickStarter watches actually turned on as soon as power was applied, and that can cause issues when the battery is very flat since the watch is trying to draw power before there's been a chance to put much more power into the battery. It's something I have since fixed and will be enabling a nice easy way to update the bootloader.

    All I can suggest is maybe put it on a radiator or somewhere warm (not super-hot) for a bit and try charging again. I don't know what the temperature is there, but LiPo batteries dislike being cold, and the combination of being cold and flat might stop the battery from getting to a state where it can take charge.

    ... but otherwise I'll have to arrange to get you a replacement. Even if we get the battery charge sorted it doesn't explain the relatively low battery life (assuming that was with the default apps and settings)

  • It's been in the mid to high 20s here recently, but I'll leave it out in the sunlight for a while and try again. Thanks!

  • Hi @walterl - any luck?

  • I've tried it a couple of times, and still no response whatsoever.

  • Ok, I'll drop you an email about arranging a replacement

  • Hi @Gordon,
    Bangle2 was working like a charm until now, This morning i noticed i had to plug it as the battery was running low. But unfortunately I forgot and it ran out of battery. Not a big deal so far.
    So I plugged it... and nothing : the screen remains blank and off, not buzzing when the wire is set on, nothing.
    I ve been waiting a few hours, expecting it would take a time before charging, I changed for another USB adapter, and then another. Still nothing.
    The back of the watch looks ok, the contactors too. The wire seems ok too. No corrosion.
    I' m a bit lost and confused, anything I could check to have a clue of the problem (hoping the watch is fine) ?

    Edit : forgot to mention it s the kickstarter one, and that I recently upgraded the firmware and bootloader. It would have been the first charge since then

  • Have you tried just holding the button down? On previous bootloaders the Bangle would turn on as soon as there was power, but sometimes if the watch got very flat that could cause issues since there wasn't enough power in the battery to turn the display on right away.

    So now the Bangle stays powered off when the battery charges up again, until you hold the power button for ~1-2 seconds.

  • oh yes ! that's it, Thank you so much !
    It worked exactly as you said
    what a relief !

  • Phew :)

  • @Gordon
    My watch "died" overnight. The standard battery indicator widget had indicated about 40%. I tried the technique you mentioned, and it worked. The display (only part of it) came back on with the battery still around 40%.

    Is it possible that the watch kept running even though the screen was blank? I have reason to think that was happening. If it was, I don't know why the watch display shut off suddenly.

  • I don't really know why it'd have turned off I'm afraid

  • No other reports of that, then? If not, I continue, not changing anything.

  • Hi @Gordon - my Kickstarter bangle.js 2 also won't charge. Its contacts seem to have turned black very quickly, within the last 2 weeks of normal use. I've worn it almost every day since it was shipped. It went flat overnight and noticed the black this morning. I gently scraped the black off the outer two contacts but it still won't charge, it's totally dead. Any ideas if this is just the contacts or do I have a more serious fault?

  • I think it's extremely likely that it's just corrosion on the contacts. I'd make sure they're all clean - try and avoid scraping - some kind of mild abrasive - even toothpaste - would be better.

    If you updated your bootloader recently the power on behaviour has changed - so if the Bangle goes flat you actually need to hold the button for maybe 2 seconds for it to boot (otherwise the screen stays blank). It may be you've just hit that, so you assume the Bangle is dead even though it isn't.

    Then after that, stick some tape over the middle 2 contacts to stop it getting worse. There's some info on:­act-corrosion-skin-irritation­iki#important-usage-information

    And on all the Bangles we ship now we put tape over the contacts to stop this happening.

  • Hi @Gordon - thank you for such a swift and helpful reply. I have done as you suggested - holding down button for 2 seconds, it has rebooted and is now taking a charge. I will follow your advice about toothpaste and tape. The sudden extreme discoloration of the pads surprised me, though - it's an issue I've been aware of and consciously checking the state of the pads. Maybe I just got sweaty in the warmer weather!

  • Great! So I guess it was just the 2 seconds to boot that was the real issue? I've had a few people complain of dead devices because of that :)

    But yes, it could just be sweat - any kind of salt has quite a bad effect. I know the one I was wearing was fine for ages and then I went in the sea for a bit and that really kicked it off.

  • I think both issues, but yes the 2 second boot was new to me and caused me to think it was dead when it wasn't!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.JS 2 no longer charging

Posted by Avatar for walterl @walterl