Web IDE: how to unflash?

Posted on
  • Hi community,
    I am working on a fork of pebble clock and I used the web IDE heavily in flash mode. Now it seems I can`t get rid of the flashed items, even when I uninstall the application it keep being executed.
    How can I get rid of the flashed items? tried rebotting and all, but nothing worked.

    I am stuck with a settings page that I cant exit and that I dont need testing anymore...help!

    thanks for your help

  • I had the same problem, deleting and re-flashing the bootloader (sounds dangerous) worked for me.
    After doing it, I found the following in https://www.espruino.com/Bangle.js+Devel­opment :

    RAM - you should normally try and use this - it writes nothing
    permanently to Bangle.js so is quick and safe to develop with.

    Flash/Flash (always) - DO NOT USE THIS ON BANGLE.JS because you will
    overwrite the existing Bangle.js bootloader with your own app (if you
    do, you can re-install the bootloader app using

  • Thanks for the hint! I did reinstall the bootloader using the app loader, but now I am stuck on a scren saying "no clock found". I have clocks installed but I can´t seem to access the settings to set them as default...

  • update: I did delete and reinstall all of the apps. Now its working. But I discovered another bug: my custom installed app can´t be set as clock. I have anton still installed and when selecting my new one it shows both as selected. If I deinstall annton I am stuck with the "no clock found" message again with no access to the settings. Sorry, but that is just stupid design...

  • Would you like to share a github link with the source of your custom app? I suspect the reason it isn't considered to be a clock lies there rather than an issue in the BangleJS firmware.

  • Sure: https://mhaszprunar.github.io/BangleApps­
    Subfolder "pebblebat". All code is ready but images are not updated yet.

    Overall I find it not useful to basically put the bandle on lockdown if you have no clock installed. You should be able to get to the settings menu at least, right?

    Other than that I have the following problems, maybe you can help:
    a) in the bangle main menu I have an entry for pebble battery, but when I use it it says "app source not found"
    b) the clock doesn´t register as clock, even though I literally copied the code from another clock.

    i am grateful for all hints!

  • Hi there @user137472- I wrote the original Pebble.

    I have just checked your apps.json file and think one of your problems is that you have called the app pebblebat - but your files are all prefixed pebbleb.something. The prefix needs to match the short name of the app. So either change the files to pebblebat.x or change the short name to pebbleb.

    When working on new clocks I would recommend having one of the stock clocks installed like Anton Clock and making sure that it is set to the default clock via the settings app. This avoids getting stuck with an error on your own clock which has been set as the default clock.

  • When developing I edit files on my lattop and then upload them to storage on the Bangle.
    So for example I often hijack the simplest clock and uploda my file as simplest.app.js. That way I can avoid having to create an icon and all the apps.json entries etc for a while.

    To upload files through the IDE
    1) Connect to the IDE
    2) CLick on drum (storage icon) in the middle of the IDE
    3) Select upload file
    4) browse to your file
    5) rename it to whatever it should be when uploaded (eg simplest.app.js)
    6) click ok
    7) restart my Bangle, navigate to simplest clock and test.
    8) repeat until happy.

  • Hey Hugh,
    First: thanks for creating the pebble clock face! Huge inspiration :)

    I did a full rename of my files and folders now and suddenly everything worked :) :) :)
    Also thanks for the hint with the direct upload, saves the time through the custom app loader.

    Will clean up now, make proer icons and put up the pull request. Thanks everyone here to help me so fast and successful!

    Greetings from Munich, Germany

  • You are welcome.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Web IDE: how to unflash?

Posted by Avatar for user137472 @user137472