• @Gordon The last couple of days I've seen that my Bangle.js 2 looses connection with my phone quite frequently. Haven't had much time for troubleshooting though (things like testing different versions of apps, both on watch and phone, etc), but today I noticed a way to trigger it.

    When pressing play in a Netflix notification the Gadgetbridge app crashes and restarts, but the bluetooth connection is not resumed automatically.

    I have debug messages active on the watch and when the crash occurs this is displayed on the watch:
    jshFlashWrite SPI addr 0x00045
    (Don't know if there's more to the message. That's all that fits on the screen and I can barely see the last 5 and most of the times only half the 4 is visible.)

    I'm also attaching an excerpt of a logcat I saved during the app crash. If needed I can send you the full thing too...

    This was observed/logs saved on Bangle.js 2, firmware 2v10.240 with Android integration 0.04 and Messages 0.09 (but I'm seeing the same with 0.10 installed) installed on the watch and Gadgetbridge 0.63.0 on the phone.

    This is probably not the only reason for Gadgetbridge crashing, since I've seen loss of connection without Netflix running on the phone as well, and I'd guess that it is Gadgetbridge crashing (for whatever reason) that is the cause of my issue.

    Edit: forgot to add that I've tried this on a clean install of Gadgetbridge too, and with versions 0.61.0 and 0.62.0 as well.

    1 Attachment

  • @johan_m_o thanks - that's really interesting!

    Is the jshFlashWrite ... message reproducible, and do you see the jshFlashWrite ... message any other times? I guess you're on a pretty recent firmware by the look of it as I only added that a few days ago.

    I'd pretty sure that jshFlashWrite SPI addr 0x00045... is complaining because Bangle.js tried to write to a certain address multiple times and didn't succeed. It's part of what I hoped was a fix for the issues where folks were finding none of their settings were applying. When I added that line wasn't expecting it to ever get called though.

    I've just pushed a new firmware (2v10.242) - if you could try that it'd be really useful as I added a minor delay in case it helps, but I also changed the message to fit on the screen and added an extra status code which might help to show what's going wrong. It's a pain as it's something I am unable to reproduce here.

    However it may actually be unrelated to the Gadgetbridge issue...

    When you added the Bangle to Gadgetbridge, did you choose to Pair, or not? If you did choose to pair, could you delete the Bangle and re-add without pairing and see if that helps?

  • The jshFlashWrite... message appears every time I lose connection due to Gadgetbridge crashing. And the address changes, the latest one read 0x00052....

    It doesn't seem to make any difference if I pair the watch or not in Gadgetbridge. I just tried without pairing, and the app still crashes.

    I'll install the 242 firmware in a moment and get back to you.

  • When pressing play in a Netflix notification the Gadgetbridge app
    crashes and restarts, but the bluetooth connection is not resumed

    I can confirm this, but with Amazon music. I opened https://codeberg.org/Freeyourgadget/Gadg­etbridge/issues/2485
    but I don't have the time to add the required logs right now. Maybe you can do it ...?

  • By the way: With other music apps it does not crash, with Amazon Music this can be reproduced.

  • @Tx I've uploaded the log on Codeberg.

    @Gordon. Tested now on 2v10.242 and the debug message on the watch, when Gadgetbridge crashed, was FW addr 0x00051fec fail Status 0. This was with the watch connected to Gadgetbridge without pairing.

  • Ah, great! Did you do an adb debug or an upload of the Bangle log?

  • It's an adb logcat captured during the crash.

  • great thanks!

  • There's an app called 'gadgetbridge debug' on the Bangle app store which may help narrow things down - it allows you to find out what Gadgetbridge sent to the bangle so we can manually enter it with the IDE connected and see what happens.

    BUT I realise I screwed up - all writes <4 bytes with the new firmware will show that error! So stay tuned for 2v10.243 which I'll upload in the next few minutes!

  • I had the GB debug app installed already, but completely forgot about it... Installing 243 now.

  • I don't get the FW anymore on 243, so you fixed that I guess...

    As @Tx mentioned above, the issue seems to be found on Codeberg. And that fits kind of nicely with the message GB debug got just before the app crashed on my phone (see the attachment).

    1 Attachment

    • PXL_20211209_163451284.MP.jpg
  • Ok, perfect - I'm pushing a fix now

  • Great - thank you!

  • Confirmed fixed in Gadgetbridge 0.63.1.

  • Yep, fixed-also working with Amazon Music now.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Bangle.js 2] Loosing Bluetooth connection, Gadgetbridge crashing.

Posted by Avatar for johan_m_o @johan_m_o