Watch working, but cant connect to App Loader or IDE

Posted on
  • I attempted to install the new Charging Widget
    It took a long time and appeared to hang
    There were no errors, I restarted my browser.
    I thne found I could not connect to the AppLoader or IDE.
    I tried MakeConnectable via settings as the watch boots fine.
    I tried 'Resetting without any code' - but could not connect.
    I tried my phone and GadgetBridge connects - wiered.
    I THEN disconnected GagetBridge as I know that would cause and issue.
    Bangle 2 still boots fine, Apps are running. Unfortunately I dont have FileManager or App Manager installed so I can delete any files.

    I am getting this error when I attempt to connect through the App Loader.

    <TOAST>[error] Device connection failed, 
    puck.js:406 <BLE> Device Name:       Bangle.js 073f
    puck.js:406 <BLE> Device ID:         1qCvgMzNqCQAzm62294LRQ==
    puck.js:406 <BLE> Connected
    puck.js:406 <BLE> ERROR: NotFoundError: No Services matching UUID 6e400001-b5a3-f393-e0a9-e50e24dcca9e found in Device.
    3puck.js:406 <BLE> Disconnected (gattserverdisconnected)
    ui.js:86 <TOAST>[error] Device connection failed, 
  • Issue solved. I could connect using the IDE with my phone.
    Cleared browser cache on my Chromebook and could connect again.
    Some very annoying issue with Chromebook bluetooth.

  • I'm finding connecting with Chrome on my Chromebook very flaky too. You'd think after all these years Bluetooth would be a bit more reliable.

  • To be fair it works fine most of the time. I get the odd issue every month or so. I keep my watch up to date with the latest App changes and am constantly trying stuff out. So I expect to hit the odd issue on the watch every now and then. I think my wifi is a bit flaky which does not help.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Watch working, but cant connect to App Loader or IDE

Posted by Avatar for HughB @HughB