gps issue

Posted on
of 2
/ 2
  • Hi, I am in Ireland. I tried every GPS app. it never showed me the GPS data. (Don't think it's prefix issue as I have waited for hours)

    When I tried the GPS Info app, I found there is 0 satellite.

    I wonder if it is the watch's GPS hardware issue or I just cannot use GPS as there is really 0 satellite in Ireland

  • Is this Bangle.js 2?

    There have been a few posts about this but it can take ages to get a fix the first time. There are some things we can do to help with that (setting time, rough location and loading AGPS data from website) but right now those aren't implemented.

    I know you said you waited an hour - was that with the watch with a clear view of the sky and with the GPS app on? If you're wearing it and moving around - especially around town - then that's going to slow it down a lot.

  • I have exactly the same problem, time is set, accurate within a couple of seconds. Bangle left on table in middle of a relatively large garden, with a clear view of the sky. GPS set to on using Bangle.GPSPower(1), Bangle.getGPSFix() ran every 5 minutes or so, after 1 hr all data is NaN, time undefined and 0 satellites. Not sure how to set location and/or AGPS data. Any help or ideas welcomed.

  • @user137174 - have you tried GPSinfo or GPStouch.

    If you use GPStouch - you should see the timestamp from the GPS start coming back and set on the lower part of the display. If the time stays at 00:00:00 then the GPS is not responding and sending GPS fix events to the Bangle. I have experienced a day when I could not get a fix outside.

    If you type the 2 bits of code below into the IDE you can see if they GPS is responding.
    If there are no events at all nothing will get printed.
    GPS touch will show the timestamp in the fix - as show below.
    If the GPS is responding then it should eventually get a fix outside.

    >Bangle.on('GPS', (f)=>{console.log(f);} );
    { "lat": NaN, "lon": NaN, "alt": NaN, "speed": 0,
      "course": 0, "time": undefined, "satellites": 0, "fix": 0, "hdop": 25.5 }
    { "lat": NaN, "lon": NaN, "alt": NaN, "speed": NaN,
      "course": NaN,
      "time": Date: Wed Dec 1 2021 00:31:38 GMT+0000,
      "satellites": 0, "fix": 0, "hdop": 25.5 }
    { "lat": NaN, "lon": NaN, "alt": NaN, "speed": NaN,
      "course": NaN,
      "time": Date: Wed Dec 1 2021 00:31:39 GMT+0000,
      "satellites": 0, "fix": 0, "hdop": 25.5 }
  • In regards to the GPS issue, how do you even turn it on or off? I don’t see anything in settings to do this. I uploaded both the GPS touch App and the GPS widget to my watch. I turned on the GPS in the GPS touch app, but the never get any satellites. The widget also never shows that the GPS is even on.

  • Ok, never mind my issue. I just got it working. I think using the GPS Time app helped get my GPS tracking up to date. So to speak.

  • Is GPS touch working for you now that you have got a first fix ? I dont think GPStime does very much more than switch on the GPS, wait for a fix and then set the clock on the bangle from the timestamp in the GPS fix data.

  • Have started a GPS issues page in the wiki at:­iki/GPS-Issues

  • @HughB
    Hi Hugh, firstly thanks for the reply. I did try GPSInfo and the GPS widget, the widget indicated that GPS was on, but despite leaving it a while outside GPSInfo failed to get any satellites. I have not tried GPS touch yet.
    I have used the IDE to set up the bangle as suggested above and after 11 hrs outside, with a clear view of the sky I still have NaN for Lat, Long , Speed, undefined for time and 0 for all other variables.
    I have set up power outside and will leave the bangle running overnight inside a plastic bag, is the UK after all. If I still have nothing tomorrow, I suspect there is an antenna problem, as the GPS chip works to some degree in that it is communicating with the IDE.

  • OK, update is that the Bangle has been outside for over 24 hours, still no fix, no time and satellites found. I am of the opinion that the Bangle is defective, not sure what else I can try.

    1 Attachment

    • 829D618C-BEC7-45DD-9255-A65CC909FA80.png
  • Ok - and the Bangle was definitely outside with the GPS on for all of that time? Because I'd actually expect the battery to run down if GPS is on for 24 hours and it's not externally powered.

    It is possible there's a GPS issue in which case I'd replace the watch for you, but I'd just like to check. Also hopefully in a month or so I should get the the AGPS and general GPS configuration situation improved

  • @Gordon
    Crude, I know. But it allowed me to keep the watch powered, in fact I had forgotten about it till I read your email, just now. The extension cable was also covered, bucket removed for clarity. Nothing has changed and it still hasn’t received any GPS info.

    If there is further checking I can do, then that’s OK, if you wish I can wait till the AGPS is online. To be honest I am out of country for a few months so sending watches, back and forth from next weekend will be a little difficult.
    At the end of the day I would just like one that works.

    Apologies if you get this twice as I replied to the notification email, which may or may not be a real post box.

    1 Attachment

    • 01324A02-375E-42D8-99C7-262A5CA39FDB.jpeg
  • Could it be that some electro smog is messing with the GPS receiver? I know: it is far fetched, but looking at this setup could very well cause interferences? I'm sure the table has conducting and ferro magnetic components and the unshielded(?) extension cord reel messes with the/creates electro magnetic waves (know that form HAMming - I hope not a magnetic loop antenna like setting). Even though the power goes in and out the wheel same way which usually 'compensates' effects, one never knows until measured. I remember from construction of the metas tower cupola, nothing conducting or magnetic was used in order to get most unbiased environmental measurements in there. That was of course decades ago... :-; - pic attached. ( @user137174, I'm enjoying your gardening...)

    1 Attachment

    • www.metas.ch_tower.png
  • Hi, Initial testing was carried out without a table or power, these were only added later to extend the time to get a possible lock. Also I have no problem with other devices getting good signals in the same area, on the same table. Though I have never needed to power them externally. So pretty unlikely.

  • Hi Mick,

    Sorry for the delay - and thanks for doing such detailed testing with it! As you say, that lack of GPS sensitivity is definitely not normal. While it seems there are some software tweaks that'll drastically improve the GPS (not just AGPS) I'm not convinced they will help in your case if it can't get a lock or even the time after 24 hours.

    I'm totally out of Black watches to send you a replacement at the moment, but should get more at the end of the year and could get something out to you in January (although I appreciate with you moving around it's a bit of a pain).

  • I have an issue with GPS as well. I have a lot of trouble getting a fix.

    The only times that I was able to get a fix:

    • pretty much always when driving a car. No matter where no matter when.
    • On a clear sunny day in a middle of a field while on a walk. It took some 20seconds and I got 5 satellites and was able to log gps data for an hour with no problem.

    I can’t seem to get a fix in a city when walking even though I had a fix while driving along the same roads with the same weather conditions.

  • I've found a GPS issue on Bangle.js 2, many "unusual" NMEA messages - not starting with $GP are sent by the GPS receiver.


    See also
    "App crash on Bangle.js 2 with GPS NMEA telegram GNGGA instead of GPGGA (contains UTC time) "
    on github:­ssues/1155

  • Interesting. I have found for Bangle 2 you have to be still in a built up area.
    I cant get a fix near my house unless I place the bangle on a dustbin outside or on the window ledge upstairs.

    I was out walking the other day and could not get a fix at all when walking. I put the bangle on top of my dashboard when I was changing out my boots and within 1 minute the GPStouch App buzzed to say I had got a fix.

  • From the datasheet @fanoush provided in another thread:

    1 Attachment

    • Screenshot 2021-12-21 215736.png
  • I've created a pull request­ull/1167 for the "GPS Info" App that adds the number of satellites in view. On my Bangle 2 I only get a fix with at least 10 satellites in view, which I've never seen indoor (around 5 in view). If a fix "from outside" is available, it continuous working indoor.
    Probably the parameters (e.g. the position quality criteria PDOP) for acquiring the first fix are set too high inside the GPS receiver.

  • That makes sense, is it possible to adjust the necessary PDOP?

  • For everyone with GPS issues who is able to download Apps via IDE, I did a quick & dirty hack:
    There is a very nice Acceleration Logger App (­ree/master/apps/accellog ) which I modified for logging NMEA data.
    As I hacked it with a minimum effort, all explanations how to use the Acceleration Logger App are still valid - it just will not log acceleration any more but raw NMEA telegrams. Also the files that contain NMEA data are still named accellog.?.csv .

    To use my attached code, do the following steps:

    • download the "Acceleration Logger" App from
    • start the Acceleration Logger App, stop it and download the data to get used to it.
    • load GPS-NMEA-Logger.js into the Espruino Web IDE or the IDE you're using and download it to RAM.
    • use it as learned above.

    The downloaded accellog.?.csv should contain something like this:


    If anyone has severy problems with GPS reception, post the .csv here (please not more than ~80 lines) and I will have a look at it.

    1 Attachment

  • Here the Banglejs2 I have, also has GPS problems:

    a) Getting a fix is hard. Running for about 3.5 hours, I've got the fix only after 2.5 hours or so.

     Another day with the same watch (that had the fix once from the first run) I could not get a fix outdoors within an hour. (All clear sky.)  And also not during a walk. (At least I think it wasn't a fix, because GPS Recorder did not record anything in the second track.)

    b) The accurracy of the track is lower than expected. I've used GPS Recorder with 3 seconds intervall and I have sometimes been ten meters or more off. The GPS on the Banglejs1 was much more reliable (yes, I know a different chipset).

  • I'm still having almost no problem getting a GPS fix with my Bangle.js 1. With the 2 I hadn't been able to get a fix until I took HughB's suggestion and laid the watch on something outdoors, keeping it still for about 5 minutes. Then I got a fix, wth 5 satellites.

  • Problem with GPS: I have a clock face that's almost identical on Bangle.js 1 and 2. Version 1 keeps good time. Version 2 gets ahead by 4 or 5 seconds a day. Both attempt to use GPS time. On rebooting Version 1, I get a notice that GPS time is being used. On Version 2, no notice of that.

    I'm using the app GPS Time with the following custom boot code:

    setInterval(function() {
      Bangle.on("GPS",function cb(g) {
        if (!g.time || (g.time.getFullYear()<2000) ||
           (g.time.getFullYear()>2200)) {
          // GPS receiver's time not set
        } else {
          // We have a GPS time. Set time
    }, (60-(new Date()).getMinutes())*60*1000);

    Should a reboot message appear on Version 2 that GPS time is being used? (Javascript is mostly foreign to me; the custom boot code is mostly Gordon's but for the whole watch the code was created by someone else.)

    The watch face code and/or the custom boot code won't run in the emulator for Bangle.js 2, giving the follow error:

    Uncaught ReferenceError: "BTN3" is not defined
    at line 5 col 13 in .boot1
    global.BTN1=BTN3; global.BTN3=_;

    There is of course no BTN3 in the code itself.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

gps issue

Posted by Avatar for TMQcard @TMQcard