USB connection issue

Posted on
  • I have 2 of the originals, Rev 1.3b. I've been trying to find if this issue has been posted before but I can't find any threads. I'm noticing that I need to have the USB connected at a certain angle, with a little pressure for it to properly connected. Tried with various cables, on both Mac and Linux. If I simply plug the cable in, it almost never connects completed, maybe 1/2 times it when I run dmesg -w I can see the device connect them immediately disconnect, and because it only remains connected when the angle/pressure of the usb port is a specific way, I would assume this is the source of the problem. Additionally, per the troubleshooting instructions, I can see that when I press the reset button, the lights come on, so power supply doesn't seem to be the issue, just the maintained connection.

    I bought these items off someone else, as part of a large package of various items, so it's not a big deal for me. But I'm wondering if this problem is common, and if there's an easy solution. I noticed I could load code in different ways, not just via USB, so I might just try this instead, although having use of the IDE would be ideal. Can I use a couple of the pins instead of the USB and still connect perhaps via a Raspberry Pi or something?


  • Hi! It'd be worth cleaning the connector with something like isopropyl alcohol and seeing if that helps. I know folks do tend to pick them up by that connector so it gets salty/greasy quite easily. You could always try adding some tape to the opposite side to pad the connector out a bit?

  • I'm not sure where you are suggesting to put the tape, and what you mean by padding it out, can you post a picture?

  • Check outĀ­-a-alternate-usb-connectors

    You can install a different USB connector on the rear of the Pico, but in terms of where to put tape, I mean putting a bit of tape on the reverse side of the USB connector (so the side that doesn't have the 4 gold contacts on it)

  • Hmm I see. This is a problem with the Espruino Original Rev 1.3b, so maybe that doesn't apply in this case?

  • Oh right, sorry! Ok, then no, none of what I said applies!

    Likely what happens is the connector has come away from the board a bit then - so I guess you could try reflowing the solder for the connections at the end.

    But yes, you could attach a USB-TTL dongle as shown atĀ­d-reflashing (minus the 'BOOT1' connection) and you can then program it pretty much exactly as you would normally. Or you could attach an HC05 bluetooth module

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

USB connection issue

Posted by Avatar for drohen @drohen