Bangle stuck with Updating Boot0...

Posted on
  • Unfortuneatly my Bangle 1 is stuck with "Updating Boot0..." after updating the bootloader.
    I can access the watch via bluetooth, but the connection breaks after short time.
    I tried uninstall all apps/install default apps, but this fails with "no answer".

    Any idea what to do?

  • When resetting without loading any code it ends with "->bluetooth" but is not connectable. Firmware is the latest one.

  • Wed 2021.09.29

    I may not be able to resolve your issue @Tx , collecting a bit more detail should assist others.

    What process/tutorial was used to update the bootloader? Link please

    After resetting using these steps, do we have the same scenario described above?­ting-without-loading-any-code

    Are you able to step through this process, and if so, at what line is the last possible?

    Updating the firmware without a smartphone­are-updates

    Another idea to try:

    Banglejs not booting
    see link   'It's usually pretty much impossible to 'brick' it since the bootloader won't overwrite itself.'

  • Hi Robin,

    thank you. I resetted it without loading any code­ting-without-loading-any-code
    I see an error: "ncaught error expecting first argu" which is strange since no app should be launched.

    I tried several times (>12) to "delete all apps" and "install default apps" in the store, but it lost always the connection and got stuck.

    However today I managed to complete the process and now I have default apps reinstalled. What is the difference to yesterday? Hm, it's the next day :-) I really don't know since the process was the same as yesterday around midnight.

    Thank you for your time.


  • Glad you got this sorted! That's a stange one though.

    My guess is maybe some app got installed that made the communications to BangleApps unreliable, but then the fact that you got 'resetting-without-loading-any-code' (unless you have some really really old firmware) is a bit odd.

  • It has been the latest stable one. The reset problem (not the original problem with update of the bootloader) might have been related to a custom start image.

  • The reset problem might have been related to a custom start image.

    Ahh - wow, yes, that starts to make a lot more sense! ncaught error expecting first argu would be part of the error from Graphics complaining that I guess you'd uploaded something that wasn't a valid image to the .splash file.

    Deleting everything in flash can take a while (30 secs or so) - did you leave it that long? Or I guess maybe if you thought it had crashed before it never got left long enough to erase everything properly.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle stuck with Updating Boot0...

Posted by Avatar for Tx @Tx