Espruino pico no serial port.

Posted on
  • i have problem with my espruino pico, the espruino works and boots in bootloader mode buth no usb connection is recognized on any pc.

  • Sun 2021.09.26

    Hi @Samux6146 a few questions.

    Q1: Did you have Espruino running previously with code you had written? by chance recall the version?
    Q2: Was an attempt made to flash the device?  re:boots in bootloader mode
    Q3: Has an attempt been made to substitute cables, or re-seat unplug/replug the cable?
    Q4: What PC OS?

  • 1)Yes i used it previously. What is a recall version?
    2)yes attemp was made.
    3)I have tried to solder a usb cable on the pcb.
    4)Linux and mac os.

  • Was attempting to determine which version was flashed.

    Not super critical to know just yet, but as the board was just flashed, do you recall which version?

    or, when the board does boot process.env­ess_env

    Attempting to determine if we have a separate flash issue or coding issue in addition to the soldering/use of additional port.

    Which pins were soldered? An uploaded image would really assist here.
    Is the intent to solder to USART1 or USART2?

    By chance are Tx and Rx reversed?
    Is there a TTL converter such as CP2102?

    Regarding OS, I'm not able to push forward further, as my experience is on Windows10 only. Others may be able to, using the detail you have previously provided.

  • i am shure the os is not a problem becouse i have already used the espruino with this pc.

    2 Attachments

    • photo_2021-09-26_20-07-45.jpg
    • photo_2021-09-26_20-07-35.jpg
  • So the cable is no longer soldered as in the photo?

    Was an attempt to perform the advanced reflashing as it was thought the Pico was bricked?
    Was SWD being done?
    Solder bridge over BOOT0 on underside of board?
    Were the battery contacts on the underside also soldered to?­flashing

    Is the desire to re-flash the device right now?

    re: 'i am shure the os is not a problem'

    I agree, I just don't know what the commands or sequence are for port communications using Mac and weak using Linux. Others will have to provide that content.

    Depending on how high that solder is on the USB tab contacts might raise one of the contacts high enough that it is no longer touching. Any chance solder wick is available to clean up those tab contacts so there is no residual solder?

  • never used a battery, boot0 pads are not bridged, tried advanced reeflash but the usb is still not recognized, and i have removed the cable.

  • @Samux6146,

    check the back of the part that is inserted into the USB socket. The contacts on the back - where you can solder on a socket - is covered with the white paint, the same one used to mark things on the board. Over time - and especially when you have tin leftovers on the USB contacts that make the board thicker and create more pressure - this paint wears off and exposed contacts short with the usb socket ground / finger springs that hold the plug/board in the socket. That could be the issue that Espruino Pico's signal are not coming thru anymore.

  • You mention you're running under Linux. Do you see any new lines in dmesg when you plug it in?

    Honestly, if it works in bootloader but not in normal mode, it could be firmware. Are you totally sure you've got an up to date firmware designed for a Pico on there? The bootloader won't stop you flashing (for instance) an Original Espruino firmware on there, in which case you'd see exactly this problem.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino pico no serial port.

Posted by Avatar for Samux6146 @Samux6146