ESP32 - Minicom working; Web IDE not working

Posted on
  • Hello guys,

    I use this ESP32 board from Olimex:­2/ESP32-EVB/open-source-hardware
    I uploaded the firmware. WiFI connect at start-up works (done with minicom).
    Although minicom is working without any issue on Ubuntu aand Windows, the WebIDE does not work on any of the OSs.

    WeIDE: on Ubuntu I can find the board on port ttyUSB0. I hit connect. I get the following message: "Connection Failed. "

    WebIDE: On Windows 10: I find the device on COM 3. I connect the device. Two messages appear, one after the other:

    1. "Unable to retreive bopard information. Connection Error?"
    2. "Connected to Web Serial, webserial:1202:6c9f (No response from board)"

    Any solution you know for this?
    As the board connects to the WiFi, can't the WebIDE connect to the board over the WiFi? - I tried and I cannot connect to the ESP WiFI network.

    Thank you in advance.

  • Windows: I Found the baudrate setting. Changed to 115200 and it worked -> Party!!!

    In ubuntu it did not work in any way:

    • Changed speed to 115200 -> still "Connection Failed."
    • I found the option to connect to TCP/IP -> still "Connection Failed."
    • I tried both the WebIDE and the Chrome App. The same results.
    • I tried USB2 but also USB3 -> "Connection Failed."
  • Same problem but on 2v10.226

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

ESP32 - Minicom working; Web IDE not working

Posted by Avatar for user134201 @user134201