BangleJS Load Problem

Posted on
  • Hey guys, pretty big problem. Got my watch today, messed around with downloading some apps to it (just like 5 or 6 small ones, no memory-breaking downloads), and then downloaded a clock app to take the place of the default one. Once I chose it as the default clock in the settings, It only showed an error message on the bottom reading "LOW_MEMORY, MEMORY". I also realized that I could not access the menu by any means from the clock. I factory reset my watch (both with and without bootloader mode just incase), and now I only get a black screen right off of the logo disappearing.

    What I know:

    1. Can connect to both App Store and Web IDE through BLE
    2. Can't load app list, "Invalid JSON" (Which I'd love to be able to view to see what's causing the problem)
    3. Can't install default apps/remove all apps, "Uncaught SyntaxError: Got [ERASED] expected EOF"
    4. Any function ran in Web IDE seems to be undefined (seems like my all of my data is deleted for some reason, not sure though)

    If for some reason it would be a problem with an app installed, the only two that I feel could have possibly caused the problem would be Gadgetbridge (which I don't believe would do this) and the clock I installed that supposedly doesn't work correctly on my watch, called Sliding Clock.

  • Would there possibly be a way to just completely factory reset the watch (like maybe from the flash)? May sound dumb, don't know too much about how it works yet as I just got it. I have nothing important/useful on there at the moment, so I don't have to worry about losing anything I've done on it.

  • Fri 2021.08.27

    Hi @LethalLeafs Not a good way to start off the weekend as I'm sure you had set aside some fun time to play. Rats!

    While I may not have all the answers, there are a few things we may try to get enough info to resolve this quickly.

    Q1: Which Bangle hardware ver are we dealing with?

    Bangle.js 2 only has a single button, while the original standard Bangle has 3 buttons

    Q2: Does the console output of the Web IDE show anything of importance, is there BLE comm?

    Upper right

    Settings >> Console

    Posting the content after the Initiaization Lines might be of some assistance

  • From post #2

    'Any function ran in Web IDE seems to be undefined '

    Could this be just a mis-understanding of how functions report to the IDE console?

    See 9th bullet

    When I type a command, why does Espruino print =undefined?

  • Post #2 'Would there possibly be a way to just completely factory reset the watch'­ng-off-if-firmware-is-broken­are-updates

    Have any of the reset attempts been tried and what are the results of each?

  • Now I realize we will need to get your Bangle responding first;


    Follow along with this recent discussion

    Problem with all apps deleting

  • Thank you for responding! I am working with the first Bangle. I am actually not around my computer today (I will be tomorrow and can update you on details necessary then) but for now, I know that I was still able to connect to the Web IDE through BLE despite the watch not displaying anything

  • It wasn't that the functions were undefined, it was a problem finding the modules. It was throwing error messages that I am supposing traced back to the module files (I do not know the file structure in Bangle yet)

  • Also, I have tried every recommendation from "Powering off" to "Deleting Apps" in the link that you sent, and nothing helped at all / could not work (throws errors)

  • Sat 2021.08.28

    'still able to connect to the Web IDE through BLE despite the watch not displaying anything'

    Great, so we confirm a 3 button Bangle 1 original and BLE is working.

    'I have tried every recommendation'

    Please try the steps below: 'Resetting without loading any code'­ing-without-loading-any-code

    Be sure to:
    1) 'Long-press BTN1 + BTN2 for about 6 seconds'
    2) Continue holding both for an additional 6 seconds

    Q1: Do you see the 'Watchdog' 'Booting' instruction on the display?
    Q2: Does the watch vibrate?

  • From Post #1 'I factory reset my watch'

    What steps were followed, better yet, would you point to the paragraph of instructions used to perform the 'factory' reset please.

  • That would be a yes to both of those questions. Still works a day or two later. Everything in the bootup and resetting process works perfectly fine up to the logo. To clarify, I am not only able to go to the logo screen, and cannot progress any further than that. I found this article with the same problem:­345403/
    But I figure that it might not be right for me since they got here from a different problem

  • And I do apologize for putting "factory" in front of that. I am not sure why I did because I just tried all of the steps to reset it in anyway possible.

  • UPDATE: For some reason it decided to work now haha. I have reset it from the buttons using this method like 5 times before now:­ing-without-loading-any-code
    But for some reason I did it, then tried it again as soon as it got to the logo, and now I am able to install the default apps on it. Don't know why it decided to work this time, but it did. Thank you for your help @Robin !

  • 'I have reset it . . . . like 5 times before now:'

    By chance were you facing East and clicked your heels simultaneously? ;-) (ref Wizard of OZ)

    Those darned 'bits' that linger around. Glad it is now working for you.

  • Great! Glad you got it sorted! Sorry for the lack of replies - it was a Bank Holiday weekend here.

    But yeah, the steps for resetting without loading code should have worked. On very early firmwares it was a bit more fiddly, but if you bought the watch any time in the last 6 months you shouldn't have to worry about that.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

BangleJS Load Problem

Posted by Avatar for LethalLeafs @LethalLeafs