Can't connect to MDBT42Q module reliably

Posted on
  • Hi there!

    I bought 10 pre-flashed MDBT42Q modules to solder onto my own boards that I designed. I've hand-soldered two of them, but can't connect to them reliably over BLE. I can only see the first board's module every now and again when I scan for it from the Espruino Web IDE, and it fails to connect to it. I'm suspecting it could be an issue with the soldering - is there a guide somewhere on how to properly hand-solder these modules?

    With the second board I can at least see it every time I scan for it (which is why I'm suspecting bad soldering with the first board), but it's still not connecting reliably. Here is the output from the console log:

    >>> Connecting...
    Set Slow Write = true
    BT> Pre-paired Web Bluetooth device already found
    >>> Connecting to MDBT42Q 5ebb
    BT>  Device Name:       MDBT42Q 5ebb
    BT>  Device ID:         uqDPqM8TCHh0fht7a3w0tg==
    >>> Connected to BLE
    BT> Connected
    >>> Configuring BLE...
    BT> Got service
    >>> Configuring BLE....
    BT> RX characteristic:{}
    >>> Configuring BLE....
    >>> Configuring BLE.....
    BT> TX characteristic:{}
    >>> Configuring BLE.....
    Set Slow Write = false
    >>> BLE configured. Receiving data...
    Connected {portName: "MDBT42Q 5ebb"}
    Got ""
    No Prompt found, got undefined - issuing Ctrl-C to try and break out
    Splitting for Ctrl-C, delay 250
    Still no prompt - issuing another Ctrl-C
    Splitting for Ctrl-C, delay 250
    >>> Sending...
    ---> "\u0010print(\"<\",\"<<\",JSON.stringify­(process.env),\">>\",\">\")\n"
    >>> Sent
    >>> Receiving...
    No result found for "process.env" - just got ""
    [notify_error] Unable to retrieve board information.
    Connection Error?
    Device found {"portName":"MDBT42Q 5ebb"}
    [success] Connected to MDBT42Q 5ebb (No response from board)
    >>> Connected to MDBT42Q 5ebb (No response from board)

    Any ideas on how can I debug this further?

  • If I reset the module (pressing button for 5 seconds on startup) I can connect to the board again, but trying to upload a program to RAM or flash causes the same issue again.

  • OK, I think I figured it out. I'm using pins D9 & D10 to talk to a I2C device, and according to this thread I needed to disable NFC first. Now it appears to work just fine, and I can even retrieve values from the I2C device (an SHT40 temperature/humidity sensor for which I wrote an Espruino library)

    I would still like to know what the best way is to solder these modules? My steps are as follows:

    1. Tape the module to the PCB
    2. Add lots of flux
    3. Put some solder on soldering iron and drag it across the pins
    4. Continue doing this until it looks like all connections have been made
    5. Use solder wick to clean up any bridges
    6. Clean up the flux with some IPA

    I skipped step 6 last night and this morning my second board stopped working. After cleaning the board it works again, which made me realise that my water-soluble flux is not no-clean flux and should be cleaned.

  • Glad you got it sorted! I'm kind of surprised the NFC configuration broke bluetooth, but maybe having the pins configured as NFC and putting power on them actually causes some stress on the chip.

    As for soldering them... I tend to apply a bit of solder paste in a line with a syringe, use hot air, and then clean up with wick, but what you're doing with soldering iron sounds fine and I've done it in the past.

    What I tended to do was actually apply solder to just one pan with a soldering iron, then position the module by hand with it melted. Then the module is held in place and I can continue soldering the other pads.

  • Mon 2021.08.09

    Similar technique to Gordon's last pp in post #4, but as my hands shake and vision is fading, I pre-tin each pin, and each pad, cleanup as necessary, apply flux, tack down one or more pads, then continue soldering using 0.3mm rosin core.

    I use a 30W adjustable down to 15-20W with a needle point tip. Along with 10x power jeweler flip down head band magnifier.

    Maybe time (for me) to invest in a hot air gun, ehh?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can't connect to MDBT42Q module reliably

Posted by Avatar for gendor @gendor