Can open launcher only with morphing clock

Posted on
  • Hi,

    In the last week i can open the app launcher (every type of launcher) only with morphing clock. If i use any other clock, bangle keeps showing the watch but buttons aren't working. So i cannot enter in the launcher and also btn 3 is reloading the page. The issue was present with old fw and also after updating to new fw. In lcd settings i put wakeup only with btn 2 and it works.

    Thanks in advance

  • Hi. Sorry for the delay.

    I'm not entirely sure I understand the problem though. Is it working now?

    What if you change Wakeup settings again back to include all buttons? Some big changes were made to Settings recently and I wonder if it just needed the settings to be changed in order for it to pull in the new code

  • Hi, no problem.

    Maybe I haven't explained well the issue. Don't consider the part regarding the buttons.
    The problem is that if I install the pixel clock (or every other clock except the morphing clock) I cannot enter in the settings menu (pressing the button 2) and I cannot reload the bangle (pressing the button 3). It is like it doesn't accept the commands, but the clock is working.
    With the pixel clock installed, the only thinf I can do is pressing buttons 1+2 and reboot; connect with web serial and uninstall the clock.
    With the morphing clock it all works.

    In the web page of bangle, it said I had an old firmware (and I was having already this problem). So I installed the latest version of firmware, but the problem is still there.

    What should I try?

    Thank you

  • What should I try?

    When you're in the app loader at and you go to the 'My Apps' tab once connected, do you see a purple "Update X apps" button in the top right?

    If so, please could you click that? My hunch right now is the 'bootloader' app is out of date - the clock apps got changed a few weeks ago to use a new function that is provided by the bootloader app for button handling, so if that's out of date then the function won't be there and the button won't work.

    If all the apps are up to date then please could you try connecting with the IDE, then going to one of the other clock faces that has the problem, and if something appears in the left-hand side of the IDE post it up here? It might help to point to the problem.

  • I found Update 1 app, and it was the bootloader. Updated, now I have installed version 0.28.
    I also put all the 3 wakeup btns ON.
    But nothing. If I install pixel clock, it appears on the screen "press btn 3 to reload", but it doesn't accept the pressing of the button. So I have to uninstall pixel clock, it appears again on the screen "press btn 3 to reload" and now it works, and I can see the usual morphing clock.

  • "press btn 3 to reload"

    How long do you hold btn3 for? You need to hold it for ~2 seconds to trigger the reload.

    You mean the "2x3 Pixel Clock"? I just tried it here, but it seems ok for me.

  • Yes I hold it more than 2 seconds. In fact when there's morphing clock the btn 3 works for reloading.
    Yes I mean 2x3 pixel clock. I tried also other clocks, but same negative result (except for morphing clock).
    Is there a way to hard reset bangle?

  • Wow, that is a strange one...

    Is there a way to hard reset bangle?

    Yes - try­ting-without-loading-any-code and then­ing-all-code

    That could be a good start in case there's something strange going on with your watch's config. I definitely haven't seen this behaviour on any other devices.

  • I tried what you've suggested (I have version 2v09) but nothing.
    Again the same problem. The only difference is that now if I install a clock (I tried 4 different ones), when I reload I find the morphing clock and I have to select the clock I've installed. Then I can see xthe clock but the btns aren't working. Before, when I installed a clock, and then reload, then I see immidiatly the clock and the btns weren't working.

    With morphing clock bangle works, and I could go on with this. It is only a pity having to give up with other clocks.

    I attach an image of the installed apps with versions (if it can help), when I installed default apps.


    1 Attachment

  • Ok, thanks for trying it, and for that screenshot - that's really helpful. So you're saying that if you do "Install Default apps" and install (for instance) 2x3 pixel clock, the middle button will no longer load the launcher?

    I'll try again here and see if I can reproduce. Is anyone else having problems?

  • Yes , I confirm that. One of these days I'll retry the procedure of resetting and let you know how's going.

  • That's really odd, I did exactly this:

    • Install default apps
    • Install 2x3 pixel clock
    • Uninstall Morphing clock
    • long-press BTN3
    • 2x3 pixel clock now displayed, and for me, BTN2 works fine

    If you connect with the IDE at and then try and display one of the clock faces where the button doesn't work, is anything displayed on the screen?

    I'd expect it might show you some kind of error, and that would really help to track the problem down.

  • Ok, I installed pixel clock, and suddenly the 3 btns didn't work. So it was visualized the morphing clock and I couln'd load the pixel clock (first time). So I connected to Espruino web ide, and it appeared (without pressing any button) this:

    Uncaught Error: Unknown UI mode
     at line 31 col 38
        throw new Error("Unknown UI mode");
    in function called from line 26 col 21

    After this, I could press the buttons and use the pixel clock. Anb again the problem of pressing the btns. Moreover when I use the pixel clock the battery icon disappers.

  • Thanks! What happens if you copy and paste process.env.VERSION into the right hand side of the IDE?

    I think what has happened is you're not actually running version 2v09, but are using a 'cutting edge' build that's not the latest - so 2v09.something.

    The build is new enough to have the Bangle.setUI function (so the bootloader doesn't try and fill it in with a placeholder) but it's not new enough to have all the functionality of the latest function.

    If you 'downgraded' to 2v09 then the situation should be better. I've also been having issues with the 'cutting edge' builds in the last few months though, so that likely won't have helped - even if you tried to install the absolute latest cutting edge build you'd probably still have got an older one with the issue. I'm hoping to get that sorted very soon now.

  • Hi!
    ok the result of process.env.VERSION is....2v09.90!!! You were right.
    I've downloaded from page­js the Release:
    So I downgraded to version 2v09, installed pixel clock, if I press btn2 I see black screen on the bangle, and I have this result from Espruino web IDE:

    Uncaught Error: Cannot read property 'bg' of undefined
    at line 1 col 230


    in function "drawMenu" called from line 9 col 10

  • Ahh, ok. Thanks for posting up the error - that really helps.

    I think all you need to do now is to re-install the bootloader, or if you're in the IDE, paste the line load("bootupdate.js") into the left-hand side of the IDE and press enter.

    Since the firmware changed, the 'boot' file that was created was out of date. Usually it's not a problem because you update and features are added, but when you downgrade things get confused.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can open launcher only with morphing clock

Posted by Avatar for user132054 @user132054