Updating boot0... (bricked?)

Posted on
  • Hi,

    I pulled my Bangle.js from back of my drawer after a long resting.

    App loader showed invalid json error so I tried "remove all apps" and "Install default apps" from About.
    I also tried reset from settings.

    After playing around with above impatiently, the watch now displays "Updating boot0..." and does nothing... for several hours by now.

    I cannot connect to it from App loader... Have I managed to brick it?!

    Any suggestions how to get back to normal?
    Need to access SWD?

  • It managed to get into DFU mode.

    After uploading latest firmware, I could connect to App loader and "Install default apps" worked just fine.

    Now I can enjoy Bandgle.js again!

  • Great - glad you fixed it! Do you remember what firmware version was on it?

    I hadn't checked this but I guess if you had something like the original 2v05 KickStarter firmware then the new bootloader might cause some issues

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Updating boot0... (bricked?)

Posted by Avatar for aerialist_user6911 @aerialist_user6911