Banglejs not booting

Posted on
  • Staring at a dark black screen of death. Nothing works. It is cold after a firmware upgrade. What to do? It is a brand new watch i got.

  • Hi - is there literally nothing on the screen at all?

    Please can you try­ing-without-loading-any-code and see if you can get anything to appear on the screen at all? It's usually pretty much impossible to 'brick' it since the bootloader won't overwrite itself.

    Also, did you try charging it? It's possible the battery just happened to run flat?

    Could you confirm which firmware you flashed too? It'd be handy to know the filename if you still have the file around. Was it the standard 2v09 Bangle.js firmware, or was it the cutting edge one?

  • It is working now. I managed to boot to DFU and upgrade to latest code.. But now another problem.. I t is not discovered in Web IDE

  • Bluetooth icon is greyed.. There is no options to turn it on /off

  • It is working now. I managed to boot to DFU and upgrade to latest code

    Do you have any idea what fixed it? Which firmware did you try and upload before that broke it?

    Bluetooth icon is greyed.. There is no options to turn it on /off

    The icon is grey because you're not connected to Bluetooth. It doesn't mean Bluetooth is disabled - the second you connect to the Bangle it'll light up.

    It is not discovered in Web IDE

    Hi, Please try the steps in­ing-without-loading-any-code again, and see if you can connect with the Web IDE after doing that?

    There are Bluetooth settings for the Bangle in (Launcher -> Settings -> Make Connectable/BLE) but if you follow the steps in that link the Bangle should always be connectable.

    I'd be pretty sure there's no actual problem with the device as you've been able to connect by Bluetooth to do the firmware update, so it may just be a configuration issue on your computer.

    If you can't connect with the IDE, click 'Status' in the IDE's connection window and see if it says anything useful. There's a whole lot of info about getting Bluetooth working at:­BLE

  • Something is not ok.
    I was at ~2v09.30, and noticed the sliding and kitchen sink clock behaved strangely. I thought it's just a bit buggy :D But looks like not: now at 2v09.33, tried removing and reinstalling everything a couple of times, but the end is the same: Watch is displayed after boot, but if I try to open the launcher, the screen turns off, and can't get it back without reboot.
    Oh, and while I can delete and upload apps, there is not progress on the display.
    If I only have bootloader + morphing clock, pressing BTN2 shows "launcher not found" message. Pressing BTN3 turns off the screen, and can't get it back on.

    Reverting to 2v09.9 solved it (no particular reason for that version, just downloaded it previously to my phone).

  • I can confirm that the app launcher screen does not function, just black, on cutting Edge 209.33.

  • Ok, thanks. I'll take a look

  • Ok, this is fixed now. The change that caused this was to do with not resetting peripherals when Bangle.js goes to load a new app (previously everything was reset).

    It definitely feels worth it to me - app loading is an awful lot snappier than it was before!

  • Updated to latest, app launcher works, but found and interesting glitch: just tried opening an app (GPS info for no particular reason), and after exited by long pressing BTN3, the screen was shifted half screen up:­4OEqzd7PO-fJXu96iUlYn2H4o/view

    It's working, I can go into the menu, I can go up-down, but the screen is still shifted:­Zx4tMQ_6a93I2BbeprTHgAXgQ/view

    And can't restore it. After launching "About", the GPS info app still seems to overlay over it:­WtNG4l1fLN4xxhpH4manAsIUs/view?usp=shari­ng

    But this is funny, the GPS info app itself is displayed fine:­JANWkKPzuofrEuXv1Uid0vQkc/view?usp=shari­ng

    But the rest of the apps are shifted up, and widgets missing.

  • Ok, thanks - I'll take a look. This is likely related to the screen scrolling code.

    edit: it's Bangle.setLCDMode - I just need to ensure we reset the LCD mode

    I didn't see this in my testing, but I guess all it would take is an app to have scrolled the screen between resets

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Banglejs not booting

Posted by Avatar for user128989 @user128989