Red light flashes once, nothing else happens

Posted on
  • I bought an Espruino wifi from Adafruit. When I plug it in, I get a single red light flash and nothing else. Doesn't matter if I'm holding down the button or not when it's plugged in. Nothing seems to work / change this. The FAQ seems to indicate maybe the button isn't working? Is there something else I can do here?

  • Hi,

    Sorry about that - did you just get the board, or have you had it a while?

    Can you connect to the board via USB? If not, please could you try a different micro USB cable? It's amazing how many dead cables are out there (many power banks come with cables that don't have data connected).

    While I guess there's some chance there may be an issue with the button, it seems unlikely that both the button and USB were broken and it still managed to pass the test.

    I think even if you do get USB communications working, if the button isn't working as you received it, it's probably something it's worth replacing the board for though.

  • Thanks for the quick response, I appreciate it. Wanted to reply quickly - I can't get it doing anything with this cable, so you may be right. I'll go find more and try a bunch and reply back. Thanks again for the quick reply, back soon.

  • OK, thanks for the suggestion. I actually had to try four (!) different cables until one worked. I am now able to connect to the device via the Web IDE and can make the lights turn on with the right JS code. However, I still cannot get it into bootloader mode to flash it. No lights ever come on when I plug it in with the button held down and release. I've tried as many different "techniques" as I can think of. I can only get the lights to do anything by writing some JS in the IDE and sending the right functions.

  • Also, I just got the board, arrived in the mail yesterday.

  • Ok, thanks! Glad the board is working at least, even if the button isn't.

    I'll send you an email now about getting a replacement out to you.

  • I still cannot get it into bootloader mode to flash it.

    at least on nrf52 you need to release the button so that it is held for less than 3 seconds, otherwise holding it over 3 seconds starts Espruino but skips running any javascript code
    EDIT: yes it is in stm32 bootloader code too­b/master/targets/stm32_boot/utils.c#L222­

  • Thanks for the suggestion, fanoush. I tried a few times this morning making sure I was not holding the button longer than 3 seconds and it still does the same thing. Gordon is helping with a replacement (whoo! thanks!) so I think we're all set.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Red light flashes once, nothing else happens

Posted by Avatar for muntzen @muntzen