GadgetBridge Notification Not Working

Posted on
  • Hi, I installed GadgetBridge from f-droid. Trying to get notification functionality to work, so far not much success. In the debug page of gadgetBridge, only 'send' works, but Test Notification does nothing.

    Another strange issue is that somehow GadgetBridge is able to connect to my bangle with BLE: Off, is that expected?

  • Not 100% if this helps but what version of the firmware are you running on the bangle?

  • ... and do you have the 'gadgetbridge' app installed on Bangle.js?

  • Yes, installed it from App Loader site, I see the blue symbol in tray.

  • I have another device, that had an older version 0.46 of gadget bridge, the test notification works correctly there.

    So I believe its related to the latest version of GadgetBridge v 0.56

  • Ok so I spent most of the day testing things. Sadly I forgot to set the setting 'notification when screen is on' on some of my tests, so wasted a lot of time.

    However, results seem that the 0.56 really doesn't work with notifications, so for now i'm sticking to the unofficial fork APK on play store which is 0.46.
    My problem is solved.

  • New issue : It doesn't always work. If I spam debug notification, then it always sends it every time. But in the real world if I trigger notifications, it has some kind of inbuilt timeout? I can't sequentially send them one by one, only the first is detected. Do you have any idea why this might be the case?
    Ideally I want it to detect every notification without any sort of timeout inbetween.

    EDIT: but maybe this is from the app that is sending the notifications, I have to test further.
    Ye it was my program that I was using.. the other apps are fine. Nvm.

    @Gordon you might wanna research why it doesnt' work with 0.56 version, if you can confirm it you can edit your details on gbridge app page github, which recommends to install latest version.

  • Hmm - that's odd - the F-Droid app doesn't seem to have been updating the apps for me.

    I just checked, and 0.56 seems to work with notifications for me, however it doesn't work with call notifications. It looks like someone's broken the cmd field so all of them just say something like GB({"t":"call","cmd":"","name":"Test","nĀ­umber":"Test"}) now.

    in the real world if I trigger notifications, it has some kind of inbuilt timeout?

    It's probably Android power saving? I think you have to exclude Gadgetbridge from Android's battery management stuff

  • Ok, not sure what's happened but I did a build from Gadgetbridge Git head and it all works - so I think maybe someone broke something for the 56.1 release but the next one will be fine

  • Another piece of information that might help someone:
    If you are using another progam that listens for notification events, it can be that this program inteferes with GadgetBridge.
    For example, I had MacroDroid running, and after disabling it, Notifications worked fine.

    Just something to think about.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

GadgetBridge Notification Not Working

Posted by Avatar for d3nd3-o0 @d3nd3-o0