Error when Initial flashing on windows

Posted on
  • After seeing on­#initial-flashing-on-windows , I tried to initial flash on windows to NodeMCU device(esp8266-esp12E).

    After executing like below command:


    But I saw the below error:

     python "..\esptool\" --port COM6 --baud 115200 write_flash --flash_freq 80m --flash_mode qio --flash_size 32m 0x0000 .\boot_v1.6.bin 0x1000 .\espruino_esp8266_user1.bin 0x3fc0000 .\esp_init_data_default.bin 0x3fe0000 .\blank.bin
    WARNING: Flash size arguments in megabits like '32m' are deprecated.
    Please use the equivalent size '4MB'.
    Megabit arguments may be removed in a future release. v3.1-dev
    Serial port COM6
    Detecting chip type... ESP8266
    Chip is ESP8266EX
    Features: WiFi
    Crystal is 26MHz
    MAC: 84:f3:eb:b4:4d:f8
    Uploading stub...
    Running stub...
    Stub running...
    Configuring flash size...
    A fatal error occurred: File .\esp_init_data_default.bin (length 128) at offset 66846720 will not fit in 4194304 bytes of flash. Use --flash-size argument, or change flashing address.

    Please let us know how to change --flash-size argument, or change flashing address.

    In addition, the type of my esp8266 board is "esp8266-esp12e-NodeMCU V2" board.
    The information of board would be refered to the link, "­ards/nodemcu-esp8266-pinout-features-and­-datasheet"

    The page shows belows info. of my board.

    NodeMCU ESP8266 Specifications & Features
    Microcontroller: Tensilica 32-bit RISC CPU Xtensa LX106
    Operating Voltage: 3.3V
    Input Voltage: 7-12V
    Digital I/O Pins (DIO): 16
    Analog Input Pins (ADC): 1
    UARTs: 1
    SPIs: 1
    I2Cs: 1
    Flash Memory: 4 MB
    SRAM: 64 KB
    Clock Speed: 80 MHz
    USB-TTL based on CP2102 is included onboard, Enabling Plug n Play
    PCB Antenna
    Small Sized module to fit smartly inside your IoT projects

    Please let us know how to change --flash-size argument, or change flashing address.

  • Sorry for this question .
    I found the miss typo of command "0x3fc0000 .\esp_init_data_default.bin 0x3fe0000 .\blank.bin"

    I solved after changing "0x3fc000 .\esp_init_data_default.bin 0x3fe000 .\blank.bin" because of 4MB, total flash size.

    Thanks to all.

  • Heh, thx for you decision !

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Error when Initial flashing on windows

Posted by Avatar for hamonikros @hamonikros