installation for MDBT42Q

Posted on
  • I've tried to compile firmware for MDBT42Q.
    Installation of nrfutil, copied from, fails.
    Any idea?

    sudo pip install --ignore-installed nrfutil
    Collecting pc_ble_driver_py>=0.14.2 (from nrfutil)
      Could not find a version that satisfies the requirement pc_ble_driver_py>=0.14.2 (from nrfutil) (from versions: 0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.10.0, 0.11.0, 0.11.1, 0.11.2, 0.11.3, 0.11.4)
    No matching distribution found for pc_ble_driver_py>=0.14.2 (from nrfutil)
  • That's an odd one. Only thing I can think is maybe it's trying to install it for Python 2.7, not Python 3?

  • hmm, good point, I ran into several problems with python-version-hell in the past
    Hmm, I'm running python 3.6.9, and pip 9.0.1, will try with other versions

  • That's odd - it should be ok. Always worth trying to update pip itself? Maybe even running pip3.6 would do it?

  • After doing some searching in the web, BTW I'm working with ubuntu 18.04.4 LTS
    Actual nrfutil version is 6, but with that I get errors around installing pc-ble-driver

    Figured out, that nrfutil V 5.22 can be installed.
    Actual installation according to pip list is

    nrfutil (5.2.0)
    pc-ble-driver-py (0.11.4)

    I've got an error and somewhere I found to do this

    export LC_ALL=C.UTF-8
    export LANG=C.UTF-8

    But now I'm running into problems inside py-sources.
    Sometimes life is not as friendly as it could be ;-(

  • Sorry, that's very frustrating. Not quite sure what to suggest....

    What command did you use to force installation of nrfutil 5.2.0 though? I'm happy to add that to instead?

  • I used pip install nrfutil==5.2.0
    SeeĀ­y for more

    But as long as I don't get it running, I would not suggest to change

  • got it running at the end (HIP HIP HURRAY)
    IMHO at the end its all about PYTHON version hell. No idea, why python3.6 did not accept nrfutil 6.1.0. Testing with TensorFlow and Opencv might have been the root of problems
    I'm pretty sure people with more knowhow around python could explain. People like me, that want to compile Espruino only, have to walk through dessert to find some water_

    This is my way to find water:

    • installed python3.8
    • added an alias for python to python3.8 in .bashrc for user espruino
    • logged out and logged in again
    • installed pip with python -m pip install pip did this because pip before still pointed to python3.6. Therefore all installation had been done to .local/lib/python3.6
    • installed nrfutil with python -m pip install nrfutil
      now I've a folder ~/.local/lib/python3.8/site-packages.AndĀ­ nrfutil is installed in version 6.1.0
      Next switched to folder with Espruino-installation and called
    • RELEASE=1 DFU_UPDATE_BUILD=1 BOARD=MDBT42Q make >tmp/stdout 2>tmp/stderr
      and it worked fine. I've got my zip for uploading to MDB42Q board

  • Thanks for the update! I bet that'll help a bunch of people.

    Yes, I have no idea why Python devs seem intent on introducing breaking changes between versions of Python :(

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

installation for MDBT42Q

Posted by Avatar for JumJum @JumJum