Can App Loader be hosted locally ?

Posted on
  • I took a fork of the main Bangle repository.
    I then cloned my repository to host it locally on my Chrombook (running Linux Beta).

    I wondered it it is possible to run the App loader locally.
    When I open Chrome and open the index.html file all I get is a display with no Apps in it.
    When I look in the debuggers console I could see complaints about CORS - so I turned that off.
    Then I have realised that various javascript cant be found as they are in paths like core/lib etc.
    When I look in git/core it does not have any files in it.

    As things stand is the App Loader bound to being hosted on github only ?

    I'd like to be able to work and test on a local repository otherwise all edits have to be done through github GUI and committed before I can do a test. Having to edit/commit on github first is quite a slow process and it also makes it harder to prepare the repository for doing a pull request later on.

    Have I missed something ?

    2 Attachments

    • Screenshot 2021-01-19 at 20.12.35.png
    • Screenshot 2021-01-19 at 19.59.32.png
  • I think the issue is you cloned out the repository, but not the submodule in core.

    Assuming you used the command-line, this should help you:­927/how-to-git-clone-including-submodule­s

  • Also most probably you need to serve it over local http server, opening files directly may not work -this is what the error message is telling - scheme 'http' or 'https' is needed, so "file://" may not work. Not only because of CORS but also Web Bluetooth API will not work from directly opened local files for security reasons (please correct me if I am wrong).

  • Also most probably you need to serve it over local http server

    Yes, this... You'll need to serve it via a local HTTP server (I missed that!) or due to security restrictions it won't be able to access other files on the computer other than those specifically referenced in the HTML file.

  • I've not come across the concept of sub-modules before in git. I just cloned my fork.

    Now tried (in the hope I did not need to setup an HTTP server).

    git clone --recursive git://
    cd bar

    But still got the same issue (no apps in the loader page).
    I dont think its going to be possible to setup a HTTP server on a chromebook.
    The linux beta (where git is installed) runs in a seperate container.

  • Do you still get the ERR_FILE_NOT_FOUND, or are those gone?

    If you get them, try running git submodule update --init --recursive in your already-cloned repo.

    I'd have thought there would be a way to get an HTTP server on a Chromebook somehow though. What about­l/web-server-for-chrome/ofhbbkphhbklhfoe­ikjpcbhemlocgigb?hl=en ?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can App Loader be hosted locally ?

Posted by Avatar for HughB @HughB