App Loader problems

Posted on
  • I've forked the BangleApps repo and submitted a couple apps already no problem but this recent one isn't working via the App Loader so just seeing what options there are to debug.

    The app actually works fine if you launch it manually from the IDE after installing from the App Loader but in the Launcher on the watch I've got a blank space where the icon would be and the title of the app. When you try pressing the middle button the app doesn't launch.

    -I've got 2v08 and the latest bootloader
    -tried deleting all apps, restarting several times
    -there are other apps already on the main repo that have the same problem on my watch atm - the Desktop Launcher is one that I don't even see come up on the menu, unless it's meant to be that way for that one...again, they load fine if I do it from the IDE after installing.
    -tried multiple different icons and options incase it's something to do with that, the icon appears ok when you load it in the IDE. Can a badly formatted icon even break loading the app from the Launcher?
    -no errors in Chrome to note

    going to let the watch go flat and see what happens after a recharge otherwise anyone got any other ideas?

    App is called HRM Data Exporter,Ā­/, doesn't do anything too crazy.

  • I'd run npm test on your PC in your BangleApps repo and see if it throws up any suggestions - that tests your app JSON for common issues.

    If the app works but the app loader doesn't, it's most likely something in apps.json. The launcher looks at a file called which is auto-generated from apps.json - so you could look at that from the IDE's storage window and see if you can see anything obviously wrong.

    You could also stay connected with the IDE while starting the launcher and see if there's any error message shown.

    the Desktop Launcher is one that I don't even see come up on the menu

    Yes, that's expected. The Desktop Launcher is a new launcher rather than an app (widgets don't show in the launcher either), so to make it work ideally you remove your existing launcher app and then it should come up.

  • @Gordon cheers! I had an inconsistant name for the app ID and I think the img name so once I updated the json it's sorted

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

App Loader problems

Posted by Avatar for BenJabituya @BenJabituya