• What with not leaving my house much for some reason, I hadn't turned on my Bangle for a while, probably over 3 weeks. When I tried yesterday, it was dead. I tried button 1, then 1+2, then every combination I could think of for 10 seconds at a time. Nothing.

    I charged it for a couple of hours and tried again. Nothing still. That is, I magnetically adhered the cable that came with the watch, which was plugged into a voltage source.

    I was literally in the middle of posting this message when my years of experience with USB cables kicked in and I had to revise. USB cables fail. So I found the charging cable from an old smartwatch, which happened to be identical to the Bangle cable, plugged that in, and the watch started immediately. It had run down to zero power during the long disuse, and coincidentally the Espruino-supplied charging cable had failed. Luckily, another cable I had lying around coincidentally could be a substitute.

    So, this message went from "request for help" to "maybe you need higher-quality cabling," I guess.

  • ... also maybe a month of disuse shouldn't cause a turned off watch to have zero charge?

  • Wow, glad you got it sorted! Sorry to hear about the cable - does it look ok?

    A few people have had issues if they leave the cable plugged in and their USB power supply doesn't have current limiting. In that case the cable can pull onto metal surfaces and can short itself out.

    But if it's just broken I can get a new one in the post to you.

    ... also maybe a month of disuse shouldn't cause a turned off watch to have zero charge?

    New firmwares should do a better job of saving power. It's not ideal, but like a lot of devices now there's not a global 'off' switch - everything is still connected to power, it's just put into a low power mode when the watch turns off.

    Also, if you turn off from the Bangle settings menu it'll go into a much lower power mode than if you use the Bootloader hold 2 buttons method (which is kindof a last-resort way to turn it off - the bootloader doesn't have the resources to communicate with all watch peripherals to turn them off properly).

  • Hi, Gordon,

    I did turn it off using the Setting menu.

    Also, it isn't your fault. Turns out it was the old cable from the previous watch that failed. The cable that worked has the little "direction of the charger" tag on it with a Bangle picture. Sorry about the mistake.

  • Ahh - that makes a lot more sense! :)

    It's surprising about the power loss when off then -and your firmware was up to date? I've got watches here and they usually last well over a month when off.

  • I could easily be remembering the time wrong. I updated the firmware the last time I wrote to whine, er, ask a question, so months ago but not the original.

  • Hi! I have the problem in the title, but for real, unfortunately.

    I'm sorry to say that I got my Bangle.js from the Kickstarter, was excited, poked at it a bit, and then didn't touch it for many months.

    I'm finally looking at it now (no time like the pandemic, post-election, to finally try to get off my Wear OS watch and onto an open source one), but I can't get it to turn on, or even suggest that it might be charging. The watch stays off and totally inert no matter what I do (like tapping button 1, holding button 1 for 10 seconds, and holding buttons 1 and 2 for 10 seconds).

    I have the original charging cable, and have been careful about plugging it in as indicated on the tag. I've tried plugging the USB end of the cable both into my Linux desktop, and into a dedicated AC-to-USB converter.

    I do wonder whether the cable is actually making contact correctly? One of the little plastic "pins" next to the metal contacts is a little bit longer than the other.

    I don't have reason to believe the cable might have shorted, but since it sounds like it could be a risk, I've ordered a replacement. I'm in the US so it will take some time to get here, though, so if there are any suggestions for things I could try while I wait, I'd appreciate it.

    I know this is going to be very hard to debug, but I'd appreciate any help anyone could give. If it matters, I'm fairly experienced with the Linux command line, though less with Espruino interfaces in particular.

    Thanks in advance for anything that can be offered.

  • Argh, sorry about this. I know you said you'd attached as in the image, but did you try attaching the cable to the watch both ways round? While the cable magnetically attaches either way, only one way actually works to charge the Bangle - although reversing it won't do any damage so just to rule anything out it's worth flipping it.

    After that I guess the first thing to do to debug would be to see if there's voltage on the charge cable pins. Do you have a volt meter? If so you could put it between the two gold contacts and check.

    If the Bangle has charge and has been turned off, BTN1 should wake it.

    If it was completely flat, plugging into the charger should start it up. Normally the screen should light but even if something fails before then the very first thing it should do is flash the heart rate monitor LED on the rear, so it'd be interesting to see if it does that.

  • It's good to know that attaching the cable backwards won't damage it, I had worried about that.

    I do have a voltmeter, and don't know why I didn't think of it! Also that has made the problem clear. The cable is giving something like 0.1V when plugged in. That would, indeed, do it. I never see the screen do anything or the heart rate monitor LEDs on the back, but then I wouldn't, with essentially no power coming through.

    So, thanks for the suggestion! I'll just wait until my replacement cable comes in, and hopefully everything will work out then.

  • Great! Well that'd definitely do it!

    Let's hope your replacement cable solves it...

  • It worked! Thanks again for the voltmeter suggestion, I'm glad I didn't spend time trying to debug other things about it. Watch looks like it's working great. Now to see if I can make the custom watch face that I'm planning on.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Watch does not turn on after long period of disuse - and it's a $2 cable

Posted by Avatar for CarlF @CarlF