v2.07 lost time when moving the watch

Posted on
of 2
/ 2
  • Since I'm using this version I get a strange behaviour: The time and date resets after approx 10 to 90 minutes - but only when I wear the watch. Everything is fine when the watch is on the desk e.g. during night and not being moved. Has anyone else a smiliar behaviour? Since it appeared together with the acceleration changes in the firmware - might there be a connection?

  • That's an odd one - does anyone else see this?

    I imagine the time change is because the watch is rebooting, but I'm not sure what would cause that. There is a possibility it's related to the code that adjusts the accelerometer polling rate based on movement, but I'm very surprised I haven't come across any issues with that if so.

  • Hm, I saw that it was running out of memory. Could be my code, but the clock app worked now since July ...

  • Ok, I could reproduce it twice: From start I have to use it about 13 min and the when I move the watch it crashes whend moved and the time ist reset.

  • It's strange that the reboot is directly connected to a movement. I downgraded to 2v06.75 and the problem disappeared.

  • Ok, it'd be related to the accelerometer power saving code I guess.

    Can you try running Bangle.setOptions({powerSave:false})?

    Go to https://banglejs.com/apps/#custom%20boot­, click the 3 bars, then paste in the code above and click upload.

    However I don't have this problem at all and if others did there'd be far more people complaining. So it must be some interaction with the software on your watch.

    Do you think you could try 'install default apps' and then re-add apps/widgets until you find what is causing the problem? If I can get the relevant app/widget to reproduce it here then I can fix it

  • Which clock face are you running / can you share the code if it is a custom one?

  • Thank you Gordon. I will try this, but "power saving" may be right keyword. I have my own clock code, which is somehow special since it is not set to sleep when the display is off. It constantly paints the clock even with display off. I know that this is not best practice but I chose this solution to get it shown instantly without delay when moving the wrist. With this the watch runs about one week (without BLE).

  • It's custom. I share it on Github this evening.

  • Ok, it's not evening, but here it is: https://github.com/profriemke/riemkecloc­k

  • I can reproduce it. Uploaded your clock to my watch (only RAM) and it crashed 3 times now after different amounts of time.
    I'm on 2v07 btw.

  • The BTN1 to turn Bluetooth off makes things a bit tricky! Even so, I'm not seeing reboots running it on my watch with 2v07. Do you have any widgets installed @Tx ?

    @Raik is there any trick to it? eg movement?

    Also are your settings 100% default, or did you change anything? I just noticed I have "wake on twist" disabled on mine and I guess that may have some effect?

  • I have battery widget, moonphase and gadgetbridge running. Yes, the display gets on on twist.
    After some time (I can repoduce approx 13 min) a twist will crash the Bangle.

  • @Raik is there any trick to it? eg movement?

    Not sure. I'm wearing it and I have wake on twist enabled. I uploaded the code and when I later checked the Web IDE it was disconnected. That's when I saw that my default watch face (Numerals) was loaded, but with a incorrect time, like 02:05.
    So it seems to reboot and "forget" the current time. Strange indeed. The Web IDE console did not show any error messages though.
    I also seems to happen very irregularly, now its running for over and hour working fine.

    BTW: I did not press any buttons in the meantime.

  • Just to say I've seen this happening with basically just @Tx's clock app. It seems to show Watchdog when it reboots, which implies that either it totally locked up, or (more likely) everything was still running fine but the accelerometer polling stopped running (which is what 'kicks' the watchdog).

    I'd be interested to see if the power saving thing has fixed it for you?

  • I had only limited time today, but I upgraded the Bangle again - reset after approx. 10-15 minutes. After disabling the power saving it did not reset anymore. But the test was pretty short today. I will test it tomorrow in a normal daily use.

  • Ok, it'd be related to the accelerometer power saving code I guess.
    Can you try running Bangle.setOptions({powerSave:false})?

    Ok, here are the results:

    1. I enabled power saving yesterday again. The watch survived the night on the table without movement, but rebooted shortly after wearing (and moving) it.

    2. I disabled power saving this morning and even after 4 hours everything is working fine.

  • It's still running without problems. It seems it's worth to have a closer look at the power saving.

  • Ok, thanks. I've filed an issue for it here: https://github.com/espruino/Espruino/iss­ues/1937

    When you get a chance please could you try installing a 'cutting edge' build? I just made a tweak - it's a bit of a stab in the dark but it might fix it, you never know.

  • Thank you, Gordon. I updated right now and I will report what happend.

  • Gordon, it seems that you found the cause. The watch in running on the cutting edge build now for four hours without problems.

  • That's great! And power saving is definitely still enabled?

    If you don't experience more crashes then I might release a 2v08 version soon as it'd be nice to get this sorted.

  • I hope that I did. To be shure I uploaded Bangle.setOptions({powerSave:true}) and afterwards I uploaded additionally an empty custom boot code.

  • With the cutting edge build I had a not responding watch this morning for the first time ever when I picked it up. It lagged about some seconds on both twist and touch. This disappeared after 15 seconds. May be just coincidence. I don't have insights what you changed.

  • That's a shame. I know the very first time you pick it up after it's been sitting for a few minutes and gone into power save it can not register the twisting movement. I guess that could be it...

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

v2.07 lost time when moving the watch

Posted by Avatar for Tx @Tx