Bangle loses time/date and freezes

Posted on
  • Hi. I got my Bangle some time ago, but what with the quarantine have rarely worn it for months. (I tend to only wear a watch when leaving my home, which I'm not doing very often.)

    Today I did wear the Bangle. I noticed that after I wore it for about 30 minutes, the time/date reverted to 20:00 December 31 1969. (The watch has never had its battery drop to zero, FTR.)

    I reset the time, and wore it all day with no problem. When I got back, I decided to install a couple of apps, because I don't like the morphing clock and the insanely-tiny-type pedometer. I made it discoverable, paired my phone, loaded the Bangle.js app loader page in Chrome on my Android phone, and tried to install the "Large Clock" app. The watch froze solid, the time stopped advancing and it didn't respond to anything short of the two-button reset. That restarted it ... thinking it was December 31 of 1969 again. I see that's expected behavior after a hard reset, but that does raise the question of why it did that spontaneously.

    I was then able to install Active Pedometer, but the atempt to install GPS Auto Time failed with the terribly useful message: "Upload failed. Unexpected response."

    Installing GPS Auto Time to fix the time travel problem required six attempts, and only worked after I turned on debug info. (I don't know if that was just a coincidence, of course.) However, despite the app loader claiming it was installed, GPS Auto Time is not in evidence and the time remains committed to the past.

    I then updated to the 2.6 firmware. I still can't install GPS Time.

    Clues? Hints? Suggestions? All are welcome. Questions are also welcome, if I can help debug this. Thank you.

  • Did "GPS Auto Time" see a GPS fix? The "auto time" letters should turn green if so. So you need to run an app which enables GPS to receive a fix, e.g. speedo or gps recorder.

    GPS auto time itself does not enable GPS because it would drain the battery really fast.

  • Hi,

    As you say, Bangle.js shouldn't spontaneously reset, but if you were running the old firmware that could have contributed to problems.

    "Upload failed. Unexpected response."

    The usual reason for that would be that 'Programmable' was set to 'off' in settings? If it happens again I believe more information should be available if you open Chrome debug console - so you could screenshot that and post it up.

    Any chance you tweaked other settings away from default, like the passkey pairing or HID? I've seen those cause some instability in the past.

    The best thing to do if something unexpected happens like this is to do the Reset Without Loading Code and then Install default apps:­ting-without-loading-any-code

    You're then basically guaranteed to get Bangle.js back to 'fresh' state, and you can work from there installing whatever apps you want.

    GPS Auto Time

    Bangle.js should automatically load its current time from the GPS when you change apps if the GPS has already managed to get a lock at some point, even without 'GPS Auto Time'. 'GPS Auto Time' just looks at the GPS data and updates the Bangle.js time whenever new time data is available. If you install and start some app that uses GPS (GPS Info?) and leave your Bangle.js near a window or outside for 10 mins then from then on you should be sorted - not that hopefully your Bangle will reboot itself after having fresh apps installed.

  • GPS Auto Time said it was installed, but as I wrote above, it never actually appeared in the app list.

  • it never actually appeared in the app list.

    The app list in the App Loader, or on Bangle.js? It's a widget so it won't appear as a launcher on Bangle.js itself if that is the issue?

  • @Gordon, thanks. I did not realize that a widget never appears in the ap list on the Bangle ... which then raises the question of how to remove it, aside from a total reset as you advised above. I'll be trying that now.

  • I tried to install default apps. I got "App install failed". The second time I tried, it seemingly worked.

    App loading appears to be working normally now. Thanks!

  • Glad it's working ok now!

    widget never appears in the ap list on the Bangle ... which then raises the question of how to remove it

    The widget should appear in the App Loader's list - if you go to then Connect then My Apps you can see and remove it.

    There's just no point having it in the launcher on the Bangle because it's not something you can just run - it runs automatically on any app that supports it

  • Thanks again, Gordon. That "runs automatically" aspect isn't clear, at least to me, from the description. Appreciate your taking the time.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle loses time/date and freezes

Posted by Avatar for CarlF @CarlF