• I tried to update over Web IDE but it failed. After soft reset there is no red light now, with button pressed there is green and then green and blue. I can't connect from nRF app or Web IDE.

    Any help would be much appreciated.


  • Hi Adam,

    Please can you try updating using the nRF connect Android or iOS app?http://www.espruino.com/Puck.js#firmware­-updates

    That'll likely be able to connect and will fix the problems.

    What Operating System were you running the Web IDE from?

  • Web IDE in Windows10 Chrome. I tried nRF iOS and it can see the device as DfuTarg when the green light is on but then fails to update (connection timeout in log)

  • Hi, Is this a new Puck.js you just got? Does the green light look bright, or dim?

    It's possible the battery is flat, and that it fails halfway through the update process.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Puckjs failed to update firmware over Web IDE and now it won't boot

Posted by Avatar for user113493 @user113493