• I can't seem to connect my Espruino WiFi over USB via WebIDE. This is the first time I am trying since I got it in December.

    I have tried all platforms I have at hand. The board is fine, I see it pulsing red and green. I see it when I list tty devices. COmes up as /dev/ttyACM0 on linux and /dev/tty.usbmodem00000000001A on OSX.

    But on both (Desktop Linux/Raspbian or OSX) if I try Chromium, the web IDE just bails out with chrome.serial not found in the debugger window. I have been able to use Chromium to connect to WebBLE (atleast on OSX) so far and WebBLE still comes up on OSX. Chromium settings show no USB devices found.

    I tried minicom on Linux but I have no idea how to proceed beyond the instructions here http://www.espruino.com/Alternative+Term­inal+Apps I'll go figure it out.

    But unless I can connect WebIDE. It seems like a massive hassle.

    Anyone else having trouble with WebIDE and Espruino WiFi ?

    1 Attachment

  • Ooh... didn't know about chrome://device-log looks like Chrome is seeing the device... meh! Okay I am out of ideas now...

    P.S. On the linux machine I did add the rules as required from here https://github.com/espruino/Espruino/blo­b/master/misc/45-espruino.rules

    (and then rebooted for good measure).

    2 Attachments

    • Screen Shot 2020-06-07 at 1.47.09 AM.png
    • Screen Shot 2020-06-07 at 1.45.15 AM.png
  • When the LEDs are pulsing red and green it's in bootloader mode. So if you're just trying to connect it to write code to it you need to connect it to USB without holding the button down so no LEDs are lit.

    But you should still be able to connect... just not get any response from it.

    So that could be an issue, but if you're not seeing Web Serial maybe you need to go to chrome://flags and enable Experimental Web Platform features? I think they get enabled on Windows/etc by default but on Linux it might need toggling.

    Also what's your Chrome/Chromium version? Are you definitely up to date?

  • Thanks @Gordon... Looks like Web Serial is no longer experimental in Chromium. It doesn't come up in flags. It does come up as enabled setting in Privacy.

    I think the only thing left for me to do is let the wolf into the henhouse - Install Chrome... Might take me a while to do that :-)

    That said this is only from OSX... I will try out my other machines and see if I can coax any of the Chromium versions to use Web Serial.


    1 Attachment

    • Screen Shot 2020-06-08 at 7.17.54 PM.png
  • You could just install the Chrome web app version: https://chrome.google.com/webstore/detai­l/espruino-web-ide/bleoifhkdalbjfbobjack­fdifdneehpo

    Pretty sure that also works in Chromium - it uses an older API that is only accessible to Web apps. Not sure how long the Web Store will stick around as Google keep threatening to kill it, but I know it does work on raspberry pi.

  • W00t! Finally... yes, I installed the Chrome Web App on Chromium that comes with Raspberry Pi OS and it worked. LED1 is blinking! yay!

    P.S. Any chance of supporting Platform IO in the distant future? I am only just getting familiar with Platform IO, but in terms of how I flashed a Wemos earlier today, if we had "Espruino" available as a framework (Wemos for examples has three options Arduino, ESPRTOS, ESP-No-OS) to PlatformIO, we could write JS files and flash/transfer them over Serial ?
    I will dig deeper into how these things interact with Platform IO when I get a chance and maybe comeback with more constructive inputs.

    P.P.S Still baffling that Chromium the browser still fails to connect to Webserial, even though the WebStore App can... oh well...

  • Great - glad it's going! Odd about /ide though - I'll have to give that a go on a Pi with a new distro and see what happens.

    As I understand it PlatformIO is C/C++ only? So I'm not sure how that'd work with JS...

  • Just FYI I tried this in Chromium on a Pi 3 here...

    I had to enable Experimental Web Platform Features in Chromium still, then the Web Bluetooth and Web Serial menu items appeared.

    It displayed all connected USB serial devices - I'd have connected but it's sitting in the loft so I can't plug anything in :)

  • Many apologies for being thick as molasses!

    When I went to chrome://flags I kept looking for Web Serial... I thought flags were all about "experimental features"

    Sigh! You are right... Web Bluetooth and Serial comes up on Raspberry Pi and OSX once "Experimental Web Platform Features" are enabled. #doublefacepalm

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Resolved] Cannot connect to Esprunio WiFi via WebIDE on OSX/Raspberry Pi/Debian Linux

Posted by Avatar for PiOfThings @PiOfThings