• I noticed an issue last week. Sometimes my clock is behind by 1 hour (see video). Could not found issue in installed apps code by reviewing it. Decided to go fresh and installed default apps and "bar clock". Issue still exist :( Any ideas?


    Now I change default clock to morphing, will see if issue still exist...

  • That's an odd one - and you're sure you are up to date with all the JS software on your watch? Especially bootloader?

    What time zone is the watch set for?

    Can you find any way to reproduce it reliably, or does it only happen sometimes?

  • Have not noticed this issue today when using Morphing clock.
    I am on newest version of all apps. Firmware 2V05.1

    0: {id: "widbat", name: "Battery Level Widget", type: "widget", version: "0.05", files: "widbat.info,widbat.wid.js"}
    1: {id: "widbt", name: "Bluetooth Widget", type: "widget", version: "0.04", files: "widbt.info,widbt.wid.js"}
    2: {id: "barclock", name: "Bar Clock", type: "clock", src: "barclock.app.js", icon: "barclock.img", …}
    3: {id: "boot", name: "Bootloader", type: "bootloader", sortorder: 0, version: "0.17", …}
    4: {id: "launch", name: "Launcher", type: "launch", src: "launch.app.js", sortorder: 0, …}
    5: {id: "mclock", name: "Morphing Clock", type: "clock", src: "mclock.app.js", icon: "mclock.img", …}
    6: {id: "setting", name: "Settings", src: "setting.app.js", icon: "setting.img", sortorder: 3, …}
    7: {id: "alarm", name: "Alarms", src: "alarm.app.js", icon: "alarm.img", version: "0.07", …}
    8: {id: "files", name: "App Manager", src: "files.app.js", icon: "files.img", version: "0.05", …}
    9: {id: "welcome", name: "Welcome", src: "welcome.app.js", icon: "welcome.img", version: "0.09", …}
    10: {id: "about", name: "About", src: "about.app.js", icon: "about.img", version: "0.05", …}

    Timezone is +3
    I'm looking for way to reliably reproduce this issue...

    I dont realy get it how this works

  • I dont realy get it how this works

    I think the person doing it had some issue and put it down to clearRect (it wasn't) to used fillRect. It looks a bit broken, but as far as I can tell it's clearing from some particular height on the screen all the way down.

  • Well, I do suspect GadgetBridge and summer time. I did not notice this behaviour before installing GadgetBridge, but after installing it- even default Morphing clock shows the same symptoms. Just to notice- clock sync is disabled in GB settings...

  • @Lixas What version of GB do you have installed? There was a bug along these lines that was fixed in v0.43.1.

  • Looks like mine is 0.43.0
    I'll try to get newer version and check

  • This issue also happens with me, regardless of what time zone I choose. It's easily the most frustrating issue I've run into, because it's difficult to know if the time actually is correct.

  • @PlaidFox are you using Gadgetbridge too? Is all your software up to date?

  • Looks like newer version of GB software on the phone solved this issue, thanks @Johan_O . Three days in a row without noticing this issue any more.

    What this implies to me, that time setting is working without GB widget application on watch, and time value is not permanent (after BTN3 long press that value is lost). I think it a bug, but this is more GB bug...

  • Firmware 2v05, Gadgetbridge v 0.44. I believe that's up to date. But let me add another clock to test it, as I'm having a secondary clock issue being addressed in another thread.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Solved] Clock is not reliable [GB application bug]

Posted by Avatar for Lixas @Lixas