• I am seeing this error when I try to update or load an app. Any clues on how to fix it?

  • Sorry about this - I pushed a 'minor' fix and didn't check it properly. If you try now it should be fixed.

  • I now seeing that the Bangle is not seen and I cannot pair. Any hints.

  • I did a reset and it connects. Now I am uploader failed ?7 unexpected response

  • Please can you try resetting like this: https://www.espruino.com/Bangle.js#reset­ting-without-loading-any-code

    And also refresh the Bangle app loader website and give it another go?

    You can get unexpected response if something else has previously communicated with the Bangle and only partially uploaded a command.

  • I tried that but I still getting this error

    Default Launcher update failed, Unexpected response [?7l
    It fails to upload apps where there has been an update

  • Can you try Install default apps? It sounds like maybe you were just updating apps rather than re-installing everything? If a previous update had failed it might have corrupted something

  • I have done a reset. I have tried to Upload the Default Launcher and the progress bar gets to about 80% but I then the same error "Expected error [?7]. Any ideas what else I can try?

  • I think I have fixed it. I went to the About tab and deleted everything. That came back with an error that it had failed. However I went to Install Default apps and that worked without any errors. I am now reloading apps I have been trying and that is working without error. Fingers crossed.

  • Ok, great! There could have been some issue with corrupted flash memory - in that case, just upgrading individual apps likely won't fix it - you need to do a complete reinstall.

    Also you might find it's worth upgrading your Bangle.js firmware if you haven't since you got it - the original firmware did have an issue where it would stop being able to update the contents of a file

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Solved] TypeError: Espruino.transform is not a function

Posted by Avatar for SimonAllen @SimonAllen