Unable to add apps from app loader

Posted on
  • Used App Loader to delete all apps.
    Tried "Install Default Apps", and receive the error:
    App Install failed, undefined

    Then tried installing individual apps, like bootloader and receive the error:
    Upload failed, TypeError: Espruino.transform is not a function

    On restart, all I get is the bangle logo, firmware (2v05), mac address and copyright.

    Can anyone assist?

  • Was able to resolve this. I had forked the app loader a few weeks ago. Ran it, and was able to upload default apps to my watch.
    So issue appears to be with banglejs.com app loader (I think).

  • Sorry about this - I pushed a 'minor' fix and didn't check it properly. If you try now it should be fixed.

  • My App Loader (Windows 10 / Google Chrome) is not able to communicate with My Bangle.Js. They connect My App tab remains trying to collect information.
    I restarted both computer and Bagle.js without a result.
    My Bangle.js screen displaces 1 row each time disconnects and connects. You can count how many times it is reconnected.
    Please see the pictures.

    1 Attachment

    • banglejs.jpg
  • the second picture didn't go with the previous post.

    1 Attachment

    • MyApps.jpg
  • What firmware version and what apps do you have on the bangle?
    Got similar issues 1-2 months ago (without connect/disconnect messages on the watch), but has been better lately. If you have an older FW version, definitely try to update the firmware and clean all apps.

    And could be an issue with your laptop / computer. For example my phone (Huawei P10, nothing fancy) is much much better at bluetooth connectivity than my laptop (a Lenovo Thinkpad Edge gen2). Totally offtopic, but my wife's 10 year old Dell has much better wifi than a newer Dell I had...

  • I bought 1 month ago and after facing the problem, I updated FW with espruino_2v05.87_banglejs.zip but situation is same. weak and unstable Bluetooth, unable to connect to Espruino Web IDE, unable to communicate to App Loader (it shows connected to App Loader).

  • Update to the latest, a lot has improved since 2v05.87 in my experience.

  • Thanks Akos. I will.

  • It's also worth making sure you have Programmable set to On in settings (the default). If you turn it off you can have issues like you see here.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Unable to add apps from app loader

Posted by Avatar for RicardoN @RicardoN