[Solved] Clock is hanging in the clock app

Posted on
  • For some time now I can't get from the standard clock app into the menu with BTN2. The button works, because I can wake up the clock with it. I tried to install the latest firmware. When trying to update the firmware to 2v05.56 with DFU I only get the error message "upload failed: insufficient resources". So I installed 2v05.48 successfully.

    Apart from the DFU mode I can't connect to the clock via Bluetooth anymore, neither via the IDE, the App Loader nor via gadgetbridge.

    Shortly before the clock app starts, "-> null" appears at the bottom left of the start screen.

    I don't know what else I could try. I'd appreciate it if someone could help me.

  • Ok, thanks - it looks like the Bangle.js firmware builds just got a bit too big in the last few days. I'll have to cut some things out and then you'll be able to upload the latest builds again.

    But it sounds like maybe you're running out of memory on the watch (or a widget is causing an error which is then stopping the launcher from coming up). Have you got any third party apps?

    -> null

    I think that happens when you have Bluetooth disabled in settings (which obviously you can't get to now).

    You should still be able to boot up without loading anything though: https://www.espruino.com/Bangle.js#reset­ting-without-loading-any-code

    If you do that you could connect with the app loader and 'install default' to make it work for sure, or could just remove a few extra widgets that you think could be causing problems.

  • Many thanks for the quick answer. I had "resetting without loading any code" tried before, but probably released BTN2 too fast. Now it finally worked. It took me a few tries to delete the apps, because somehow the bluetooth connection broke down often, for whatever reason. But now the clock works again! :)

    Apart from the apps of the App loader I had only tried my own clock app, which was not set as default. But I had played around with the HID feature before.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Solved] Clock is hanging in the clock app

Posted by Avatar for user111163 @user111163