• So, I haven't made any changes to my Bangle.js in a few days. I check the app loader and see something I want to add, connect, and it fails to do so. I've done a hard reset to the watch (btns 1+2, then release btn1), reloaded the browser, connected back to my phone, disconnected from phone, reset the settings on the watch, activated "make connectable", all to no avail. Sometimes the browser waits a few seconds, or sometimes it's immediate, but it always returns with "device connection failed, undefined." Any suggestions?

  • After trying to connect from my phone (Opera browser) instead of my computer (Chrome), I was able to connect without any problems. For some reason, this is only happening in Chrome. Sort of no longer an issue, except that it's more convenient to use my computer. Let me know if you guys have any thoughts on the matter.

  • I have had some problems connecting with Web Bluetooth on Chrome after a while that just requires a restart of Chrome. As it's often my main browser, this can be a pain.

    So, try installing Chrome Canary just for Bangle / Espruino so it can be restarted easily. I've taken care not to install any extensions or do Google log-in on Canary, so there are no bookmarks or other distractions. That way, I'm less likely to accidentally use Canary for other things.

  • Have you checked that your computer is NOT paired to Bangle?

  • I'm not sure what OS you have, but I've heard of a few cases where Mac OS just gets confused and the whole Mac just needs a reboot, then it works fine.

    Also worth opening the Chrome developer console and seeing if it reports a more useful error

  • Hi all.... I get the same error message when I try connect the app loader with the WebBLE App on IOS. The WebBLE App will not work correctly afterwards. I have to close and restart it to work. But connect to my Bangle is not possible.
    Is this a problem of the App or then App loader Website?
    With Chrome on MacBook I never had any problems.

    Walked through all FAQ and troubleshooting advices i found at the Website. Nothing helped.

    Some hints for me?

    Thx 😊

  • Hi,

    The WebBLE App will not work correctly afterwards.

    How doesn't it work correctly?

    Have you tried just turning Bluetooth off on your phone and back ok?

  • With my β€žwordingβ€œ I would say the navigation at the bottom has been dropped .

    It happens when you scroll up... I add 2 Screenshots. Maybe this explains it.

    First screen is with and second without.

    2 Attachments

    • 5E679B83-8B27-44D2-B1B1-1C71D9A9820E.png
    • 61A75F2D-B332-44FD-A74C-0243BBA15003.png
  • @daphtdazz I don't suppose you've seen anything like this happening for you have you?

  • @mstaatz you should be able to get the bar at the bottom back by tapping at the bottom of the screen (where it should be). That's a feature, not a bug :-)

    I haven't tried the Bangle with WebBLE yet, @Gordon do you have any non-ancient iOS devices lying around you could give it a go with?

  • Thx @daphtdazz for guiding me 😊 sorry that I am not clever enough for finding that by my self. On iPhone 11 you have to tap very close to the end of the screen... I got this now.
    But I can not get it connect either.

    @daphtdazz @Gordon FYI the log from the app;
    Log: GET window.localStorage = null
    Log: Initialising Notifications
    Log: Initialising Status
    Log: Initialising Utils
    Log: Initialising Config
    Log: Initialising Serial
    Log: Initialising CodeWriter
    Log: Initialising Modules
    Log: Initialising Env
    Log: Initialising Assembler
    Log: Initialising GetGitHub
    Log: Initialising Pretokenise
    Log: Initialising SaveOnSend
    Log: Initialising SetTime
    Log: Initialising CoreModules
    Log: Device Name: Bangle.js f266
    Log: Device ID: 1B4E6573-42ED-4DB0-AD41-08D94912228F
    Log: Connected
    Log: Got service
    Log: RX characteristic:{"value":null,"listeners"Β­:{}}
    Log: TX characteristic:{"value":null,"listeners"Β­:{}}
    Log: Sending "\u0003"
    Log: ERROR: ReferenceError: Can't find variable: Buffer

  • Thanks for the log - I'll take a look. I don't believe Buffer itself is used in the code, but it may be some quirk of Safari that it complains about code referencing it even if that code isn't called.

    However I'm pretty certain many others have had success with WebBLE so I'm not sure what would cause yours not to work.

  • No Problem. I am happy that you will look into. Meanwhile I can use Chrome on MacBook, either.
    WebBLE on iPhone would be cool. So I am waiting... maybe you can find something.

    Thx 😊

  • Ok, just managed to find and fix it after battling iOS for a few hours. It was actually a difference in how the two browsers execute JavaScript code - I thought those days were long gone :)

    Should work again now though!

  • Perfect, Thank you so much. This makes my day 😊
    Tested and works well.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

App Loader Device Connection Failed, Undefined

Posted by Avatar for PlaidFox @PlaidFox