BLE cannot find puck.js

Posted on
  • I have two puck.js, received a few months ago. I had paired both in IDE and everything worked. Then they went in the drawer somewhere.

    I got them out today. Upgraded both to v2.05. One paired with the IDE and works well. The other does not seem to show up at all during BLE Select. I have hard reset it a few times. The self-test seems to pass. It seems functional, just does not connect/pair.

    How do we forget a Puck that was paired before but does not now show up?

  • Is it possible that a phone/PC/etc is still 'paired' to the Puck so is auto-connecting to it?

    You could also try powering up the Puck while holding the button - that'll clear out any saved code and Bluetooth Pairing info that there might have been.

  • I have made sure that other bluetooth devices are no connected to it.

    I've reflashed the Puck with v2.05 using nRFTool. I also powered up while holding the button (until beyond the 5 red blinks).

    On the desktop, I reset its bluetooth module so that it has no memories of prior pairings (I had to re-pair my keyboard and mousepad).

    In this fresh start, the other Puck appears quickly in web IDE and is re-paired.

    The web IDE still cannot seem to find this Puck during 're-scan'.

  • I used another computer and managed to see two entries (9663). I did not pair then.

    I returned to the first computer and was able to find the Puck and pair with it.

    Solved. Thanks! But why the two entries?

    1 Attachment

    • Screen Shot 2020-04-28 at 8.18.06 AM.png
  • But why the two entries?

    Is it possible you'd tried using NRF.setAddress at some point in the past to set custom Mac address?

  • Not as far as I know. Both Pucks now behave well. Thanks.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

BLE cannot find puck.js

Posted by Avatar for user106712 @user106712