Black Screen on new watch

Posted on
  • Hi,

    I have a black screen on my new watch, it won't come on. The connector is correctly connected, I tried connecting it to different chargers. Exactly once it came on while connected to a USB battery. I was happy to see that and saw the battery meter icon > 50% full and disconnected it from the USB charger and it turned right black again. Did not come back since.

    I tried just about all button combination I could think off. Any hints ?

  • Ok, but the screen did actually come on once? Can you connect to Bangle.js via bluetooth?

    Can you get it to come on again by connecting it to the USB charger again?

  • What happens if you press button 1 and 2 together for 5 seconds? It should restart the watch.

  • It worked fine for 1-2 weeks. I tried pressing 1 + 2 for 5s, for 10 s, for 30s . It does NOT come on when connected to the charger. not overnight. The only time it came on was when I left it connected to the USB charger for a little while and came back as described above. The moment I disconnected it, it went black and stayed black for now. No matter whether I reconnect it.

    It is not visible via BLE , which it was flawlessly before this problem

  • Thr 2020.04.23

    I realize it was stated in #1 post, but lets totally rule out the obvious. When looking at the face of the watch, which side E vs W does the cable lie beneath when charging?

    Regarding #2 post by Gordon, assuming the watch is on, are you able to detect it from another Android device, or connect to it using the online WebIDE? Are you able to pair?

  • I had something similar happen a few weeks ago with the screen blank and the watch completely unresponsive. I guessed that it might be in some sort of uninterruptible loop as the watch seemed to be discharging quickly. The screen was blank and no bluetooth connection so I estimated this by measuring the charge current after leaving the watch for a bit. I fixed it by opening up the watch and shorting out the battery to force a reset. After doing this, I reconnected the charging cable to reset the battery protection circuit. A safer way would be simply to wait for a long time and then reconnect the charger:).

  • @user109471 is yours a Beta KickStarter received back in December, or the new release received in March?

    I just had a similar scary moment with my Beta KS watch that just black screened. As I had just read this, panic set in!

    Had just read 'Hold Btn 3 in to return to clock':­ng+Started

    but instead, screen went black!! I was playing with GPS yesterday assisting in a separate forum thread, and as GPS is a power hog and I did leave it on overnight, wondered if the battery went dead. Connecting the charger did not work either, although I could see a slight backscreen intensity increase when depressing Btn 1.

    The only way to recover was to follow the suggestion in #3 post, and count out loud to make sure a long five seconds, and device did then reboot. Just an FYI

  • Do you have a voltmeter handy? I guess it's possible that your charge cable has broken?

    • Cable going out East (towards the buttons) as per the sticker on the cable (which is the only way it was ever connected anyway)
    • Cable works fine with December version of the watch (which still works fine, other than the ring that broke off and was glued back on).
    • New one was way better though as it reliably allowed me to connect remotely to it whereas the early version had lots of issues with that

    Also the one moment it DID come on (while it was connected to the USB battery) it showed > 50% battery. The moment I disconnected the screen went black. I would assume a hardware issue with the display if BLE still worked.

    What is the BLE MAC range of the watches ? I could check whether BLE is showing up when scanning via phone, which might indicate a display issue. It is not connecting via the normal means though.

  • Could be a faulty battery as well.

  • Absolutely could be the battery. What to do though ?

  • Actually yes, from what you say it sounds like a faulty battery. I could post you out a new one if you're willing to send the old one back.

    If you're ok with this, it'd be easier if you could remove the watch straps as per­sembly and shove it in a jiffy bag?

    Sending as a 'large letter' (<25mm thick) is just way cheaper than trying to post the whole box :)

    What is the BLE MAC range of the watches ?

    I'm not 100% sure of the range. I think realistically if you don't see Bangle advertised then it's probably not working.

  • I can send it back. But I think I would first test using the other battery I have from the other watch if I can disassemble myself. Is the watch still watertight afterwards ?

    With MAC Range I meant the range of numbers assigned as MAC addresses :)

  • Is the watch still watertight afterwards ?

    If you put the ring back right, yes.

  • Yes, ad @Purple-Tentacle says it's fine.

    The only gotcha is the battery is soldered to the main watch PCB with reasonably small wires, but if you have a fine-ish soldering iron you should be fine.

    If that turns out to be the issue then I can actually just send you a replacement battery and there's nothing to send back.

  • The video linked above does not show how to remove the battery though. I am afraid to break something important if continuing without understanding the internal structure.

  • You basically peel the buttons off and then the whole thing 'unwraps' from the black plastic Puck - however the button connections are reasonably small.

    I think it might be better to just send it back and I'll get a replacement out. I'll send you an email.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Black Screen on new watch

Posted by Avatar for user109471 @user109471