BTN 2 stuck

Posted on
  • Hi,

    My Button 2 is stuck.
    It still works, but it does not "click" anymore. The feedback when pressing is a bit annoying that way. You do not really know if you clicked or not.

    Is this a known problem?
    Can I do something about it?


  • Wed 2020.04.08

    Christian, Don't know if it is a 'known problem' but I would hate to think this is another quality issue?

    'Can I do something about it'

    After watching the dis-assembly video, maybe the internal circular holder has shifted. Maybe a shim on the opposite side might reduce the distance clearance?

    It appears you may be the pioneer here, the one with all the arrows in your back.

  • Thanks.
    It still works, so not a huge problem.

    Watching the video, I think the spring mechanism is inside the button.
    I will wait for some more answers, maybe someone can give me a hint.

  • @Purple-Tentacle is not the only one I also have had this issue. It actually seems to be related to the inner parts. After disassembling the Bangle (wanted to check on the piezo and remove the inlay of the display) the button is "clicking" again. It's distinctly less tactile, than when I received the watch, though :/

  • Not sure what to suggest - I had this on one or two early watches (and asked the factory to check the buttons), but hadn't noticed it on the recent batch. Given what's happened so far I'd be pretty sure they didn't actually test anything though :(

    It's actually possible that just applying some kind of lubricant would help? The watches do seem to have something applied at the factory, but maybe they missed that button.

  • My button is not stuck anymore, I did nothing to fix this. Lets see if it will get stuck again.

  • Had something similar on one button. Pulled out a couple times, and it's OK again since...

  • Just wanted to post my experience here. My BTN2 is acting up lately. It has a strange haptic to it. If I press it firmly to select a clock from the launcher it often brings me back to the launcher right away. Just like it isn't released fast enough or being pressed a second time.

    However I can also trigger it by pressing it ever so slightly, but without giving me feedback with a click. I tried lubing the pin, but I guess it is also more a problem of the inner button itself.

    EDIT: I disassembled the watch again and the internal buttons seem to work fine. It is indeed the outer button that is being stuck/stiff sometimes. Does anyone have a tip how to remove (and get back on! ;-)) those tiny c-clips?

  • Does anyone have a tip how to remove (and get back on! ;-)) those tiny c-clips?

    I just tried it with one here and it wasn't too painful, but I'd still be wary. Just some notes:

    • Used a pair of thin needle-nose pliers to turn the clip around until the opening was pointing towards the back of the case, then pressed on either side of it to push it down. It came off easily BUT it pinged about 0.5m away - I'd try doing it somewhere where you're more likely to find it if it bounces off the table!
    • To put it back on, it helps if you can hold the button half-in, half-out, so the ring cut into the button for the C-clip is right near the edge of the watch case - it then helps to keep the clip nice and flat. I then just pushed on the back edge of it with the needle nose pliers again.

    But yeah, I think the main issue is losing the C-clip when it pings off :)

  • Used a pair of thin needle-nose pliers

    Thanks for trying. I need to get myself some special tools first then :-D
    I guess a pair of tweezers won't grip tightly enough...

  • I guess a pair of tweezers won't grip tightly enough...

    Tweezers should be fine. You don't actually have to grip at any point - you just need to be able to push each side of the C-clip at the same time.

  • you just need to be able to push each side of the C-clip at the same time

    Ah, yes got it. I didn't read careful enough. I'll give it a try tonight.

  • Ok, short update. I got the c-clip off (luckily it jumped right on my thumb) and removed the button.
    Seems like the inner o-ring that seals the button wasn't lubed properly anymore. I lubed it and reassembled it. I also masked the inner buttons with one layer of electrical tape to try to improve the haptic of the button.

    Seems to work. Hopefully I don't need to redo the lubing regularly.

  • Unfortunately I need to follow up on this. I'm still having trouble with the buttons, the responsiveness is getting worse.

    Can @Gordon or someone else please measure the inner diameter of the hole of the button pin and the diameter of the tiny o-ring on the pin if you have an open case laying around?

    I thinking of either widening the hole a tiny bit or to cut down the o-ring. This will sacrifice water-tightness but I'd rather have working buttons really.

  • My button changes back and forth between stuck and normal.

  • Honestly, not sure how accurately I could ever measure that hole. Did yours definitely have a spring inside it?

  • BTN2 definitively has a spring. Thats the one I opened and lubed, and now works ok'ish. BTN3 works fine for now. BTN1 gets stuck/unstuck regularly, but I am pretty sure it has a spring.

    What seems to work is turning the buttons and pushing them a couple of times. But that only lasts for a few hours.

    I really don't want to remove that c-clip more than once for each button. It's a royal pain.

    Oh well, I'll keep watching it.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

BTN 2 stuck

Posted by Avatar for Purple-Tentacle @Purple-Tentacle