• Hi all

    Received my device. Tried to install and test two apps. So far so good.
    Went to Settings check what is there. (Probably) enabled show debug log. Then everything get down in spiral:

    1. I could not boot to my clock any more.
    2. Updated firmware via android nRF toolbox application
    3. I still can not boot to my clock, looks like something is incorrect with files in user area. Pressing BTN3 goes to blank screen...
    4. AppLoader webside does not really help: it receives installed apps list, but does not allow to remove or change neither app- goes with error. On developer toolbox (f12) i do not see any response from BLE when "install default apps" is pushed.
    5. I can connect with ide, get list of files. But it does not hhelp. Tried require("Storage").eraseAll()
      but id does not help, or at least i dont know how to use it

    Is there any way to install firmware and rewrite user space with default content? Probably something corrupted there

  • Have you checked the troubleshooting docs?

  • Thanks. yes, I did checked. It does not help. Step 4 on my post talks about that

  • There are also other ways to reset, although I now saw that that particular link was found a bit further up in the troubleshooting docs:

  • "Remove all apps" or "install default apps" goes with orange error on website. Here you can see, that it succesfully received getInstalled Apps. Then clicking any button on websitr just fails- website does not get response from watch...

    1 Attachment

    • error.png
  • Ok, this happened to someone else. I'm still not 100% sure how - but basically there was a bug in 'Show Debug Info' which caused the watch not to be contactable.

    However somehow the watch/settings app has managed to get removed, but not the code that looks at the settings and causes the problem.

    All you need to do is update the Espruino firmware itself, to the latest build from: http://www.espruino.com/binaries/travis/­master/

    After that, you can boot while pressing BTN1 (as you did before), but NOW the watch will be contactable and you can re-upload all the apps.

  • looks like my watch IS contactable, i do get list of installed apps. I already flashed newest firmware, on watch i can see 2v05.436. I can connect in web id and get list of files on device, and separate file content...
    But i can not re-upload apps, website just tells "app install failed, " chrome on Win10 or Android

    Anyway, i've just retried firmware update, but no change (as i already did this earlier)

  • I'm just guessing wildly (as you might already have surmised), but have you tried "Resetting without loading any code" from the link I posted earlier?

  • Thanks Johan, I did tried that. But i'm still stuck, as i can not use "Deleting all code" section

  • I have saved my watch:

    1. Yesterday disabled totally
    2. Today enabled
    3. Got to Web IDE (Win10 Chrome), connected, and on left hand side terminal executed following

    4. Opened new tab, got to App Loader website, connected, and executed "install default apps" It took about one minute, and everything went smoothly
      I have brand new watch. I'm happy!! :)

  • Thanks! This just made me realise what was wrong. I'll update the app loader later today, and it should then be able to recover Bangle.js devices correctly.

  • I have the same problem, but unfortunately solution does not work. I just updated the firmware per #6 (2v05.1). I can't do the web ide trick, though -- can't connect via BLE. Actually, immediately after a reboot, I can manage to pair, but then "connection failed". Same behavior with the app page.
    Ideas, pls!

  • It can help to open the app launcher and to connect with it open. This saves memory because widgets are not loaded.

  • Re-flashed firmware 2v05.438 and I’m back in business. Not sure what caused my original problem; I had not made any changes to the Show Debug Setting. My Problem happened after changing the default clock.

  • Hi,
    I'm having a similar issue but my watch is never contactable...I went through the DFU mode with the upload of the zip file. But when I reboot my watch is still not reachable...what am I doing wrong?

    1 Attachment

    • Bangje_Stuck.jpeg
  • Looks like you solved this already at http://forum.espruino.com/conversations/­349027 ?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Solved] Stuck on BangleJS logo. Wish to do factory reset...

Posted by Avatar for Lixas @Lixas