GPS Recorder stops without reason

Posted on
  • I tested the GPS Recorder app at my Bangle and I got two problems:

    I tested tracking my regular Nordic Walking round course, which runs about one hour.

    Afterwards, when I download a gpx file from the watch and showed the track in Google Maps, I only saw a part of the walking track: After a few minutes the Bangle started writing coordinates., but after about 40 minutes the track ends abruptly (I double checked with an file editor). This behavior is reproducible.

    My second issue is, that kml import to Google Maps is not always working: In the second test run Google Maps produced a vertical line at my meridian instead of the expected track, although in the editor the kml file looked good to me. I then tried gpx format download instead of kml and this worked partly as described above.

    Any idea how to fix these?

  • I guess it's possible that the GPS data file on Bangle.js is actually fine, but it's the download to the PC that is causing the issue? I think there may have been some issue if the download took more than 30s...

    If you go into the GPS recorder app in Bangle.js and look at the track, how many 'records' does it say there are? Does that tally with the amount of records there are in the KML file that's produced?

  • Did some hiking yesterday, and yes, the export did seem to stop ~halfway thru.

    But: Run the export three times to KML and once to GPX, and the output stopped at four different times: roughly 2140-2150 records. It did not stop at the exact same time / record number.

    And something was always wrong with the last record:


    18.95,47.86064,NaN << less significant digits in longitude, my position wasn't at "18.95"

    Last GPX:

          <trkpt lat="47" lon="NaN">

    But 2: copy-pasted the App Loader's console output from the browser, did some replace on the raw text, and looks like my whole trip is there, it was transfered by the Bangle, but the culprit is the parsing or export to GPX / KML.
    5589 lines, 3 second interval -> some timestamps are missing, start and end timestamp and coordinates seem to be valid.

  • Ok, thanks - looks like it's this issue then:¬≠ssues/119

    I'll need to get on and come up with a fix for that.

  • I think you are right: The GPS Recorder app reports 4,050 records, but the KML file only has 2,160 records.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

GPS Recorder stops without reason

Posted by Avatar for Peter_Bernscheider @Peter_Bernscheider