"Alarms" app feedback

Posted on
of 2
/ 2
  • Hi,

    • I think it ignores time zone (I'm at UTC +1, nothing happened at the set time. Set the alarm time one hour earlier, and now it does alarm)
    • The actual alarm seems to start only when I press a button (or press BTN3 for a long time?). Set the alarm, display is on, I see the time morphing to the time I set (ok, actually, one hour earlier), and nothing happens. Long-press BTN3, and the alarm starts. No alarm at all when display was off :O
    • You can set minutes to invalid values like "14:-6" and "14:66" 😸
  • Thanks - I'd fixed the invalid values thing before lunch but it seems I had lost track of my changes. I'll look into the other stuff :)

  • Ok, hopefully all fixed now!

  • Looks like the whole "My Apps" is broken. Console output:

    <BLE> Device
    <BLE> Device ID:         kKsxYtu9ceGDvngSyUmfSw==
    <BLE> Connected
    <BLE> Got service
    <BLE> RX characteristic:{}
    <BLE> TX characteristic:{}
    <BLE> Sending "\u0003"
    <BLE> Sent
    <BLE> Busy - adding Puck.eval to queue
    <BLE> Executing {"type":"eval","expr":"require(\"Storage­\").list(/.info$/).map(f=>{var j=require(\"Storage\").readJSON(f)||{};j­.id=f.slice(0,-5);return j})"} from queue
    <BLE> Sending "\u0010Bluetooth.print"
    <BLE> Sent
    <BLE> Sending "ln(JSON.stringif"
    <BLE> Sent
    <BLE> Sending "y(require(\"Stora"
    <BLE> Sent
    <BLE> Sending "ge\").list(/.info"
    <BLE> Sent
    <BLE> Sending "$/).map(f=>{var "
    <BLE> Sent
    <BLE> Sending "j=require(\"Stora"
    <BLE> Sent
    <BLE> Sending "ge\").readJSON(f)"
    <BLE> Sent
    <BLE> Sending "||{};j.id=f.slic"
    <BLE> Sent
    <BLE> Sending "e(0,-5);return j"
    <BLE> Sent
    <BLE> Sending "})))\n"
    <BLE> Sent
    <BLE> Received "Uncaught SyntaxError"
    <BLE> Received ": Expecting a valid "
    <BLE> Received "value, got var\r\n at "
    <BLE> Unable to decode "Uncaught SyntaxError: Expecting a valid value, got var\r", got SyntaxError: Unexpected token U in JSON at position 0
    <BLE> Received "line 60 col 1\r\n\r\n^\r\n"
    <BLE> Received "in function called f"
    <BLE> Received "rom line 1 col 145\r\n"
    <BLE> Received "....id=f.slice(0,-5)"
    <BLE> Received ";return j})))\r\n     "
    <BLE> Received "                    "
    <BLE> Received "     ^\r\n>"

    Opened the "oldapps", and that can still read one app, the "Gps info" for some reason...

  • Unexpected token U in JSON

    Maybe try reloading all apps - looks like one of the uploaded info files has invalid JSON in it?

  • Ooops, yes, that was Gps Info v1.

    But found another smaller issue:
    After installing or updating an application, it will show up as "Unknown app undefined" in the "My Apps" tab. If you update more, there will be two unknown apps. Hitting "Refresh" in My Apps solves this.

    1 Attachment

    • 2020-02-28 17_59_16-Bangle.js App Loader.png
  • I just updated a bunch of code so hopefully it'll be more resilient to bad JSON in the future.

    Ok, thanks about the app error - I'll have to look into that later as I'm out of time now. I'll file an issue for it.

  • Thanks for the fixes!

    The Alarm app itself: there is some weirdness:

    • The screen was on, it's worked as expected :)
    • If the screen is not on, it's not "alarming" all the time. Sometimes it does, and everything is ok. Sometimes not, and the watch goes crazy until the alarm is actually displayed. Pressing buttons was ineffective: the watch did respond to BTN3 long press, but the screen was erased about after a second (backlight still on). The watch was unusable until the actual alarm is displayed (I guess that was at the start of the next minute?)
    • Setting the alarm to the current minute pretty reliably reproduces that weird behaviour: save the new alarm setting, go to the main watch face, and after about a second nothing is displayed and no buzzing.
  • Did you update the bootloader firmware as well? The Alarm is partially implemented in that (to allow it to work regardless of whether widgets are displayed or not), so you may not have actually got all the fixes yet :)

  • Yes, Bootloader v.0.07, Default Alarm v.0.02.
    Definitely did happen one more time: had an alarm on, and the same weirdness happened on saturday again.
    Fw version 06a6ca5. But the "About" app says NO bootloader, NO launcher, NO settings. But I do have all of those. Is this a bug in the "About"? Maybe that wasn't updated with the new file names / settings?
    I will try a fresh install...

    Edit after total reinstall (fw + default apps):

    The alarm seems to work, if the screen is off, and the watch is not doing anything.
    I get the same weirdness if either:

    • an app (in this case the compass) is active when the alarm should go off
    • set alarm to current minute and quickly long-press BTN3 to get to the main screen

    The "About" app still says NO bootloader, NO launcher, NO settings. But I do have all of those. I think this a bug in the "About" app.

  • Thanks - just fixed the About page issue.

    I think I figured out what the other problem was too - the alarm app wasn't taking seconds into account so when it got loaded it didn't think there was an alarm ready. At that point it should have reloaded the default app (clock) but it looks like load() fails when it's called directly from startup code.

    I should have fixed all that - so if you update alarm and about your problems will hopefully be sorted.

  • Hi Gordon and once again, thank you for the watch !
    Well, I upgraded the Bangle.js (firmware, settings and some other apps) but the alarms app is not working.
    "New Alarm" shows "New Alarm" and "Back", not "Save".
    The new alarm is not saved and there is no way to delete an alarm.
    Alarms app is absolutely not working...
    How to fix it ?

  • If you want a new Alarm, choose New Alarm, configure it, and choose New Alarm, then it'll be saved. I just tried it and it works fine.

    I guess we could rename the second New Alarm to Save?

    But yes, as you note it seems there is no way to delete an alarm. I'll look into that.

  • Gordon
    Thank you for the answer BUT:

    • I choose Alarms app,
    • I choose "New Alarm"
    • I set my alarm and choose again "New Alarm"; my alarm seems to be there, so I choose "Back" and I come back to the hour but the alarm icon is not shown.
    • I choose Alarm app again: my alarm is not there.
      It doesn't work. Sorry.
  • @Gordon Yes, even with Alarms App v0.06 it doesn't seem like the alarms are actually saved.

  • Just tried here:

    • https://banglejs.com/apps/
    • Install Default Apps
    • long-press BTN3
    • long-press BTN3 to exit welcome screen
    • BTN2 - launcher
    • Select Alarms and launch
    • Choose New Alarm
    • Choose Save
    • Choose Back

    Alarm icon is shown in top left. Entering Alarm again shows the alarms.

    Does it work for you if you follow those exact steps? Do you have something different on your watch maybe?

  • I can do a reset a bit later and just get the Default Apps on there, but currently doing theses steps:

    1. BTN2 - launcher
    2. Select Alarms and launch
    3. Choose New Alarm
    4. Choose Save
    5. Choose Back

    Nothing... No alarm icon in the top left and when going back to Alarms the alarm is gone. The alarm is shown in the list after step 4, but no icon and no alarm goes off (and isn't actually saved as seen when going back into the Alarms app).

    I did get the icon and the alarm was actually saved one time (after several tests back and forth), but I've not been able to get it to do that again even though I'm following the same steps.

  • Hi every one.
    Gordon, I followed the steps you've done and Alarms app is running as expected (I can create a new alarm, save it (yes !), see the icon that warns me there is an alarm and find it again (and modify) in the Alarms app).
    And, I also can delete it !
    So, it worked, Thank you !

  • Hi there,
    I just tried this (watch is on factory settings)[worked on first try]:

    1. BTN2 - launcher
    2. Select Alarms and launch
    3. Choose New Alarm
    4. Choose Save
    5. Choose Back

    And an icon appeared in the top left corner. It also vibrated when it hit the time.

  • @Gordon Ok... Following your steps I can set an alarm just fine. But, as soon as I have set the watch up with my prefered apps it stops working. I'm attaching a screenshot of the "My Apps" tab for reference.

    I tested going back to Morph Clock and Default launcher, but it made no difference.

    1 Attachment

    • apps_list.png
  • I just reset my watch, tried it and it worked.
    Installed apps (they are not causing this):

    1. Pipboy watch
    2. Day left widget
    3. Battery widget with percentage
    4. Gadgetbridge
  • Please can you try and narrow it down a bit to see what makes it not work for you, @Johan_O?

    Also, if you connect with the Web IDE and just try setting alarms and loading the main clock face, you might see if it reports some error that would be helpful in tracking it down?

  • @Gordon Yes, I will sit down and narrow it down further later today. I did hook up to the Web IDE to see if I could catch anything when setting an alarm, but nothing...

  • Just another wish...
    Gordon, I just added a piezo buzzer in my Bangle.js and I set piezo as 'Beep' in the Settings. The piezo buzzer sounds
    But, the alarm doesn't make a sound... Just vibrating, no more...
    Does the app checks in the Settings the choice of 'Beep' to sound what the user wishes ?
    Thanks for all !

  • @Fram No, the alarm app only buzzes, there is no beep implemented. It's only a tiny change though.

    @Johan_O: Can you see an alarm.json file containing the correct data when using the Web IDE file browser?

    Should be looking something like the screenshot below

    1 Attachment

    • alarm_json.jpg
  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

"Alarms" app feedback

Posted by Avatar for AkosLukacs @AkosLukacs