• This morning uploaded the latest master firmware, and settings doesn't work.
    Exact version:

      VERSION: "2v04.76",
      GIT_COMMIT: "624d6f2",

    The screen becomes blank when I try to start the settings "app".
    No visible error on the watch, or via the bluetooth console.
    The watch is responsive to button presses and is working if I connect via bluetooth, but the settings doesn't show up.

    Tried cleaning all apps, storage, reset(1). And only uploading the bootloader, settings and the morphing clock. Same result.

    Does work with

    VERSION: "2v04.78",
    GIT_COMMIT: "62c95c4",

    Maybe I will continue with a binary search in version if I have some time :)

  • Please can you try removing all apps and reinstalling from https://banglejs.com/apps/ ?

    The newer versions had some big changes. I think the one that caused a problem was that Settings (and the app manager) used Bangle.menu which I've had deprecated for a while and which I finally removed.

  • Yes, it's working now!

  • I upgraded to 2v04.76 on Friday and ran into exactly the same problems - settings menu wouldn't open. I tried clearing all apps and reloading them but the problem persisted. Tried again yesterday having read this message and voila - it all worked again. So thanks for posting this - I had been contemplating waiting for the official watches to arrive but now I've got a working beta again.

  • Yes, unfortunately there may be changes that break things and require a full update in the next few weeks.

    It just feels easier to break things now and end up with a good clean design than to do it when all the watches are out there!

  • I think anybody with a beta should report any tiny issue, because it might be a legitimate issue Gordon didn't discover. Or addition to docs / faq. I think...

    Yes, break stuff now. Turn the world upside down if you must, if that yields a better watch in the end :)

  • I think anybody with a beta should report any tiny issue

    Yes, definitely! Please let me know if you hit any issues :)

  • After being stuck also in the same situation described above, it might help some people to know that, in order to remove successfully all the apps using the online app loader, I had first to downgrade Espruino to an older version (such as 2v04)...

    Only then was I able to delete the apps.

    Then was I able to upgrade, to reinstall the apps on this upgraded app-free Espruino, and have them working properly...

  • If you are stuck:

    • Reboot without loading any code (release one of the buttons, follow the on-screen instructions). In this state you can connect via BLE.
    • Now you can connect with the app loader, and remove all apps.
    • If not, connect via the web ide. reset(1) and require('Storage').eraseAll() should remove all code.
  • @sebi thanks - but I'd be really interested to hear what issues you had with newer versions. As long as you can do what @AkosLukacs suggests as in the post above to get connected, the App Loader should work fine (under the hood it does require('Storage').eraseAll() itself)

  • The main issues I had upgrading to a newer version were:

    • apps didn't work properly (e.g., Loading... displayed forever),
    • impossibility to connect over BLE (with the App Loader or the WebIDE).

    I did try:

    What worked for me was what I describe in my previous post:

    • to downgrade the firmware first (DFU upgrade over BLE did work),
    • to successfully connect over BLE (with the App Loader or the Web IDE),
    • to erase all the apps,
    • to upgrade (performing BLE DFU upgrade),
    • to connect over BLE successfully (with the App Loader or the Web IDE),
    • to reinstall the apps.
  • resetting without loading any code didn't help - it still went straight to watch mode

    Hmm - that's odd. Just tried again here with the latest firmwares and it works great. It's implemented at a very low level so no matter what is in flash memory it'll always work.

    If you figure out how to reproduce it then please let me know and I'll look into it.

  • Launching without any code did work for me.
    Might (might!) be similar to the issue when you can't turn off after updating from older firmware: the watch just restarts for one-two times if you try to turn it off?

  • Hmm - that's odd.

    Indeed, I might have messed up triggering resetting without loading any code properly?!? It is complicated (if not impossible due to my probable mistake) to reproduce. Let's forget about it. My bad.

    This remark is for me: After releasing BTN2, make sure to keep BTN1 pressed till the watch has finished rebooting not to load any code. (If not a standard reboot only will be triggered.)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[solved] Something is not right with 2v04.76 / 624d6f2 build

Posted by Avatar for AkosLukacs @AkosLukacs