Posted on
of 2
/ 2
  • As it is working pretty well for me, I would rule out:

    • Bangle.js firmare
    • GB widget on Bangle.js
    • Gadgetbridge on phone (current version form F-Droid)

    Which leaves us with:

    • Phone settings (do not think so, as you made battery settings)
    • Phone ROM
    • Phone hardware

    BTW, I am using a Pixel 4XL with current Android version.

  • ROM and hardware have been on the top of my list as well. Which is the main reason I'm switching ROM soon.

    But, now that you mention it I have been using the MarioClock the past couple of days, which has its own GB implementation. I did see connectivity issues before that as well, but hadn't started investigating until after switching over to MarioClock. I'll test some more with the GB widget active.

  • Haven't seen any difference depending on what widget/clock that's being used. MarioClock might seem to be loosing connection more often since it buzzes on connect/disconnect, but I'm seeing the same kind of successful/failed connections in the logs no matter what...

  • Have you tried enabling the GadgetBridge logging? It can be enable in the settings and writes a log file to /android/data/¬≠dgetbridge

    Maybe something can be seen from there.

  • I'm going to let my face and palm get better acquainted for a moment... I had seen that setting but for some reason I just did not think about enabling it. Will do. Thanks.

  • Is HID definitely off in your Bangle's settings?

    I've also noted that sometimes a reset of the watch (BTN1+BTN2) is necessary to be able to connect from my computer

    Yes, I wish I could track this down but it does seem to be an issue in the Bangle.js firmware. Usually it only happens when you're alternating between having the BLE settings off and on though.

    Thanks for the logs. Interestingly the btm_sec_disconnected seems to give reason : 8. Which I think is BLE_HCI_CONNECTION_TIMEOUT. It seems it could be related to the bluetooth clocks not being 100% accurate on either the phone or watch.

    Do you have a phone that doesn't have a custom ROM to test with?

    Other thing you can do is maybe upload some some like:

    NRF.on('disconnect', function(reason) { 
      E.showMessage("Reason "+reason,"DISCONNECT");

    And see if bangle.js gets the same reason code?

  • I've only ever enabled HID once, first or second day of receiving the watch when testing stuff. Since then it's been off the whole time.

    I'll take a closer look at troubleshooting this later in the week, and I might even install a stock ROM to see if that makes any difference... I only have this device as my daily driver though, so I rarely have an opportunity to do too much crazy stuff with it.

    Searched a bit and it does seem like reason 8 is BLE_HCI_CONNECTION_TIMEOUT.

  • @Gordon I've been doing some reading to try to understand more about how BLE works. Not quite there, but I did find some info about what you mentioned about the clock accuracy and BLE_HCI_CONNECTION_TIMEOUT, and that it possibly could be helped by increasing the PPM (example).

    I have absolutely no idea if that is even relevant, but wanted to just air the idea and see if there may be something I could test in this regard.

  • I'd already checked that before posting I'm afraid. Bangle.js is already using the 20ppm mode and I'm not sure we can get much higher...

    But if Bangle.js works on other devices then chances are it's not Bangle.js's clock that's out, but your phone's!

  • Yeah, I've been suspecting all along that it is my phone that's the culprit.

    I did dig up an old Google Nexus 6 I had laying around and got that up and running yesterday, but it has the same issue with randomly dropping the connection. I'm gonna test with my wife's phone next...

  • I had the same problem trying to find my bangle on Gadgetbridge, even though I could connect perfectly fine on chrome.
    What worked for me is downloading Gadgetbridge through F-Droid, instead of the Play store.

  • The Play Store release is not the official one.

  • Quick update.

    As already expressed earlier in this thread, everything points to it being my phone that is causing this issue. As a test, I let the phone stay awake, with the screen on, for 2 hours, all the while having the watch connected and going about as usual (made sure to not get too far from the phone to avoid disconnecting caused by distance). After that I turned the phone screen off and let it stay like that for an additional 30 minutes.

    During the first 2 hours (screen on) there where 2 instances of the watch and phone losing connection (reason 8 both times), but it was quickly reestablished (within a few seconds). In the last 30 minutes (screen off) there where 25 connection state changes, of which only 9 where successful connection attempts and the rest failed (8 reason 8 and 1 reason 34 from an active connection, and 7 reason 133 when trying to reconnect).

  • I couldn't work out how to use Fdroid (all searches came back empty) for my Google Pixel, so I assumed I had the wrong type of OS and I downloaded via Google Play.
    Did I do wrong? Is the Google Play version secure? What is the downside of using this version? Haven't had any connectivity problems so far.

    Very excited about using Bangle.js btw
    Awesome and wow thank you!

  • Were you not able to get it from ?

  • The issue is that the Google Play version is a non-official one. The hope is it's just done by someone that wants to make the process easier for everyone, but we don't actually know whether they added anything to it.

    It'll be older than the F-droid version too - It looks like it works fine with Bangle.js now, but originally it was old enough that there wasn't any Bangle.js support in it.

  • The download link to the apk file for the latest version 0.47.1 is this one:¬≠urgadget.gadgetbridge_180.apk

  • Hello parasquid, I wasn't, but I tried again just now and installed everything with no problems. Thanks very much.

  • Thank you :)

  • thanks Gordon

  • You're welcome, glad I can help :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview


Posted by Avatar for Andreas_Rozek @Andreas_Rozek