EspruinoHub installation fails on Raspberry Pi 3

Posted on
  • Hi, I'm trying to get EspruinoHub to work on my RPi.
    I'm on Raspbian Stretch and all packages are up to date. No manually installed "special" versions of any kind.

    I'm following the steps from here:; I'm only interested in the EspruinoHub and Web IDE Part, no need for NODE-RED.

    The Setup fails at the "npm install" part with the following errors:

    pi@raspberrypi:~/espruino/EspruinoHub $ npm install
    (node:16913) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
    npm ERR! Error: Method Not Allowed
    npm ERR!     at errorResponse (/usr/share/npm/lib/cache/add-named.js:2­60:10)
    npm ERR!     at /usr/share/npm/lib/cache/add-named.js:20­3:12
    npm ERR!     at saved (/usr/share/npm/node_modules/npm-registr­y-client/lib/get.js:167:7)
    npm ERR!     at FSReqWrap.oncomplete (fs.js:135:15)
    npm ERR! If you need help, you may report this *entire* log,
    npm ERR! including the npm and node versions, at:
    npm ERR!     <>
    npm ERR! System Linux 4.19.42-v7+
    npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install"
    npm ERR! cwd /home/pi/espruino/EspruinoHub
    npm ERR! node -v v8.11.1
    npm ERR! npm -v 1.4.21
    npm ERR! code E405
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/espruino/EspruinoHub/npm-debug.­log
    npm ERR! not ok code 0
    pi@raspberrypi:~/espruino/EspruinoHub $ 

    I'm not really familiar with node.js and npm, and I suspect the environment setup is not correct. I installed node & npm from the defailt raspbian repos.

    Any Ideas?

  • Hi - sorry for the delay. This got buried amongst a bunch of other stuff.

    I'm not sure what to suggest here. I just tried with a totally standard install of 2019-09-26-raspbian-buster-lite.img which appears to be the recommended version at the moment, and it works great copying the instructions exactly.

    Is it possible you had used npm install before, but with sudo npm install so that it had set some of its permissions up wrong?

    If you don't have anything else on it, I'd imagine a fresh install and following the instructions for the just EspruinoHub and the IDE would work fine.

  • As far as I remember I tried both with and without sudo. It's quite possible that something got mixed up in the whole NodeJs ecosystem, which I'm not familiar with. I'll try again with a fresh raspian install sometime soon.

  • It's a node version thing. You can see the error is deprication.
    With node it's simple to move to different versions to try. On Mac/Linux use the "n" on windows use "nvm "

    it's common to have to switch versions and if that's all your running then the right version fixes all problems.

    Switch to 6.0

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

EspruinoHub installation fails on Raspberry Pi 3

Posted by Avatar for Gefrierbrand @Gefrierbrand