• Hello everyone!
    I'm using ESP32 DevKit with espruino_2v00_esp32
    NRF.setScan(), NRF.findDevice() - work fine.
    NRF.connect() and BluetoothRemoteGATTServer.connect() return ERROR: new parameter in esp_ble_gattc_open ???
    I've tried almost all examples from Espruino Tutorials.
    Any suggestion?

  • Sorry,
    there is a major change in BLE API.
    I'm still working on a solution for that.
    GATTC needs ble_addr_type which is not used in Espruino (at least AFAIK)
    According to esp-idf examples it appears in an GAP event (ESP_GAP_BLE_SCAN_RESULT_EVT)

    Definition is

    typedef enum {
        BLE_ADDR_TYPE_PUBLIC        = 0x00,
        BLE_ADDR_TYPE_RANDOM        = 0x01,
        BLE_ADDR_TYPE_RPA_PUBLIC    = 0x02,
        BLE_ADDR_TYPE_RPA_RANDOM    = 0x03,
    } esp_ble_addr_type_t;

    Any idea to understand this parameter would be big help

  • I think this is in normal Espruino nRF52 builds:


    As I understand it you have 2 basic address types that everyone uses:

    • public = Guaranteed to be unique in the world
    • random = Guaranteed to be unique locally (Espruino uses this one)

    There may be others but those are the 2 that get the most use.

  • Hello

    I have a exactly same problem with 2v05 version.

    NRF.connect("9c:aa:1b:c0:48:3b private").then(function(server) {


    NRF.connect("9c:aa:1b:c0:48:3b public").then(function(server) {

    doesn't work at all. What's wrong?

  • Well, as ESP32 is an unsupported device not all functions are working/available, like the one you tried.

    But you are welcome to fix/add functions for the ESP32.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

ESP32 DevKit WIFI+BLE / BLE connect problem / ERROR: new parameter in esp_ble_gattc_open ???

Posted by Avatar for Engineer @Engineer