Hard Reset MDBT42Q Breakout board

Posted on
  • An error occurred when uploading code direct to flash with the IDE, and now my MDBT42Q Breakout is not working correctly. I can connect to it with the IDE, but a red error rect comes up in the bottom right of the IDE saying it can't get board info, and the REPL is not responsive. I figured I'd try a hard reset, as I've had work on the Puck, but I don't see instructions how to do a hard reset specific to the MDBT42Q. I've tried the following:

    1) Remove power. Press and hold BTN. Apply power. Keep pressing until red LED1 turns off.
    ~~This didn't result in any different behavior in the IDE from what I described in the opening paragraph.
    2) Remove power. Press and hold BTN. Apply power. Keep pressing BTN for 20 sec.
    ~~Same as above
    3) I tried to reload the firmware by putting it into firmware mode (hold BTN upon power and immediately release, red LED1 stays on). This indeed sets the device name to DfuTarg, but the nRF Connect app isn't able to connect. If I try to pair with my phone, it connects but then immediately disconnects DfuTarg.

    Anything else I can try?

  • Thr 2018.09.06

    Hello @jijidad, I may not be able to provide any more assistance than what you have already tried. I had a similar situation recently with a Pico. Would you please take a glance at that post to see if there are similarities.


    @Gordon will need a few more bits of information, and to quicken an answer to you, would you be able to provide:

    The version of IDE and which one; Native, Chrome, or Web access.
    The version of Espruino using: process.env and would you please post that entire response content.
    The size of the code file you uploaded.
    Please note any similarities with what was posted in the thread above.

    This detail will assist Gordon with a frame of reference and quicken the response as you have provided detail he will most likely require.

  • Hi @Robin, good call. Thanks. Here's that info:

    Chrome App version of IDE (0.69.1) on Mac
    Espruino version:
    VERSION 1v99
    GIT_COMMIT f0d66ba
    FLASH 524288
    RAM 65536
    SERIAL 38d11204-ee97e646
    CONSOLE Bluetooth
    MODULES Flash,Storage,net,dgram,http,NetworkJS,c­rypto,neopixel
    EXPTR 536882348

    Size of code: Was relatively small. Just a few functions I was testing from a larger project.

  • Did you happen to observe whether or not the Green Send Progress bar halted mid transfer.
    (lower right corner)

    And if so, the IDE became unresponsive at that point?

    And whether this has occurred on previous other attempts?

  • Hi @Robin, I seriously doubt this is related - as I said in a previous post your issues were related to uploading on an STM32F4 over USB. This is Bluetooth LE.

    @jijidad, how did you manage to get the board info you posted up if the IDE has never managed to connect correctly? Or does it manage eventually?

    If it's because you haven't actually restarted the Web IDE since it stopped working, please can you give that a go? Make sure you save any code in the right-hand side :) I think the 0.69.1 IDE could get itself into a state where connections failed the way you're seeing - but a restart would fix it, and I also updated it very recently so if you're using the app, on restart you should hopefully see a version 0.70.3

    What you did (with the very long press at boot) should have worked fine to clear everything out.

    How are you actually powering the MDBT42? When I've had issues like that (being able to see the Bluetooth device, but not even connect with nRF Connect) it's actually been because the battery has been extremely flat. Basically it provided enough power for it to boot, but when connecting the battery can't supply enough power to keep it going and it stops working.

  • @Gordon, I have a bunch of the same devices and so grabbed the board info from the one I switched over to after the other stopped working.

    Rebooted IDE. I'm still on 0.69.1 though... Maybe I should reinstall the Chrome app...

    Low Battery! I should have thought of that. Maybe low battery also caused the file loading glitch in the first place?... With charged LiPo, the board is working well again. These boards are awesome. Everytime I think I've bricked one, it comes back to life. I've never experienced this level of robustness on other platforms...


  • If you try chrome://extensions/ there should be an Update button at the top - that might work?

    Great news it's working! I'll update the troubleshooting page with that as well :)

  • The update button in chrome://extensions/ did the trick. Now on 0.70.3. Thanks!

    Interesting note: This version of the chrome app now says its name is "Default bleoifhkdalbjfbobjackfdifdneehpo.app", whereas the version I had before said "Espruino Web IDE.app". Not a big deal...

  • Was excited to find this as it's very similar to my issue (http://forum.espruino.com/conversations/­332237/) but unfortunately my IDE is up to date and power is not an issue :/

    I thought it may be helpful to link my issue here in case anyone else encounters something similar :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Hard Reset MDBT42Q Breakout board

Posted by Avatar for jijidad @jijidad