Espruino Hub on Raspberry Pi no Ports Found

Posted on
of 2
/ 2
  • Can you try running mosquitto_sub -t "#" and see if that works?

    It looks from the log messages like mosquitto may not be installed. The Hub is then failing to connect and crashing.

    If you followed the instructions at it really should have worked though. Specifically the sudo apt-get install mosquitto mosquitto-clients bluetooth bluez libbluetooth-dev libudev-dev bit

  • Gordon,

    I reinstalled everything, one more time...slowly and checked for errors. There were a couple of path errors but once I went through the complete process for the 4th or 5th time (I am a bit slow)... I then started everything...and it finally worked for me.

    Thank you so much for hanging with me on this. I appreciate it. Now I need to learn more about the programming side and sending information back to a main server for access in a dashboard.

    Looking forward to getting it going.


    1 Attachment

    • Espruino.PNG
  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino Hub on Raspberry Pi no Ports Found

Posted by Avatar for PapaTech @PapaTech