scripts/ and /home/vagrant/.bashrc

Posted on
  • When I run scripts/ on the home linux box running Linux Mint, it works fine.

    When I try to run it on a linux instance on Amazon, I am told:

    -bash: /home/vagrant/.bashrc: No such file or directory

    I asked two expert friends, and they were both baffled. The more knowledgable of them said "whether or not a vagrant user is created will be highly dependent on the packaging" and that "it depends on a user that 100% will not exist on anything that isn't a vagrant vm, unless said server is very weird" - when I told him that it worked on my mint machine at home (which I don't have access to until thursday), he insisted that I must have run a different script. Apparently vagrant is something to do with VMs?

    So - can anyone tell me if it's possible to set up an Amazon EC2 instance and build Espruino on it, and if so, what incantations must be recited?


  • I’d be inclined agree with your friend, that you are running different scripts. Sure it was and not

  • As @Ollie says, I don't think there's anything in scripts/ that'd try and access .bashrc - whereas does specifically reference /home/vagrant/.bashrc

  • What the hell... something went wrong in the git fork. My repo is WAY behind, using the version of the script from 2015... I wish I'd realized that was the problem.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

scripts/ and /home/vagrant/.bashrc

Posted by Avatar for DrAzzy @DrAzzy