• Hi Espruino Savants,

    I am trying to use the Espruino Command Line module on a Windows 10 PC. I type
    "espruino -p COM18" because my ESP8266 module is on COM18 (works fine with the WebIDE) and get a
    "No compatible USB Bluetooth 4.0 device found!" error. (Full error output message below.) Did I miss some setting?

    PS C:\Users\dan\Documents\Espruino\code\Esp­ruino> espruino -p COM18
    Espruino Command-line Tool 0.1.5
    Connecting to 'COM18'
        throw new Error('No compatible USB Bluetooth 4.0 device found!');
    Error: No compatible USB Bluetooth 4.0 device found!
        at BluetoothHciSocket.bindUser (C:\Users\dan\AppData\Roaming\npm\node_m­odules\espruino\node_modules\bluetooth-h­ci-socket\lib\usb.js:70:11)
        at BluetoothHciSocket.bindRaw (C:\Users\dan\AppData\Roaming\npm\node_m­odules\espruino\node_modules\bluetooth-h­ci-socket\lib\usb.js:28:8)
        at Hci.init (C:\Users\dan\AppData\Roaming\npm\node_m­odules\espruino\node_modules\noble\lib\h­ci-socket\hci.js:101:35)
        at NobleBindings.init (C:\Users\dan\AppData\Roaming\npm\node_m­odules\espruino\node_modules\noble\lib\h­ci-socket\bindings.js:82:13)
        at Noble.<anonymous> (C:\Users\dan\AppData\Roaming\npm\node_m­odules\espruino\node_modules\noble\lib\n­oble.js:55:24)
        at _combinedTickCallback (internal/process/next_tick.js:73:7)
        at process._tickCallback (internal/process/next_tick.js:104:9)
        at Module.runMain (module.js:606:11)
        at run (bootstrap_node.js:389:7)
        at startup (bootstrap_node.js:149:9)
    PS C:\Users\dan\Documents\Espruino\code\Esp­ruino>
  • Hello Espruino forum ,
    I have exact same problem as DanB.
    Here is some of the things I have tried:

    a) Installed WinUsb driver as suggested here: https://github.com/noble/node-bluetooth-­hci-socket
    That instantly disabled my bluetooth mouse and kb, followed by a slightly panic situation until a treasury hunt for cabled devices in the basement was succesful :-)

    b) Running with "espruino --no-ble".
    (version 0.1.13 of Espruino CLI)
    No effect.

    c) Also tried "npm remove noble".
    No effect.

    Could someone please help out a newbie ?

    br Lars

  • I got it to work finally like this

    1. Make sure to use node 11 at the time of writing node12 seems to have some issues with building
    2. install from elevated terminal

      3. Connect with correct parameters (I can only supply the ones that worked for my ESP32)

      --board ESP32
      --port COM6
      -b 115200

  • Thanks to @Relief.Melone i got it working on Windows 10 and node v12.13.1 with my ESP8266 / NodeMCU

    $ npm install -g espruino
    $ espruino --port COM3 --board ESP8266 -b 115200 --no-ble
    Espruino Command-line Tool 0.1.32
    Explicit board JSON supplied: "ESP8266"
    Connecting to 'COM3'
  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

"No compatible USB Bluetooth 4.0 device found!" error with Espruino Command Line on Windows

Posted by Avatar for DanB @DanB