• (I've looked through existing threads but didn't find anything relevant to my case so posting a new thread)

    I have an older mac (iMac 27-inch, Mid 2011) that does not support BLE (Apple logo ->System Report->Hardware->Bluetooth->Bluetooth Low Energy Supported:No) so I followed the instructions here:
    https://www.espruino.com/Puck.js+Quick+S­tart#with_web_bluetooth , namely:

    1) Unpair Bluetooth devices using internal Bluetooth
    2) sudo nvram bluetoothHostControllerSwitchBehavior=al­ways
    3) Restart

    The steps worked as I then saw (Apple logo ->System Report->Hardware->Bluetooth->Bluetooth Low Energy Supported:Yes). The MAC address of the external bluetooth USB is also showing correctly (option+bluetooth icon).

    However, when I go to the Espruino Web IDE although the puck is detected right away, after choosing it and clicking connect, the connection takes a very long time and almost never happens.

    I also have a MacBook Air (13" early 2015) with BLE enabled (no dongle needed) for which the connection to the puck is instant and I have no issues.

    Both my machines are running OS X High Sierra

  • Have you ever updated your Puck.js's firmware? On older Puck.js devices the firmware didn't advertise the Puck's presence very often, and on some computers that made it difficult to connect to... that could be your problem?

    Your title says 'after upgrade to macOS High Sierra' - is there something you missed out of your description - like it working fine before you updated your Mac?

  • I had not updated it before. But I did update it today (lv95). And have the same problem. Yes it worked very well before I updated my Mac. I will correct the title now. Thanks a lot for your response - much appreciated

  • I had a quick google about this, and it looks like Apple actually removed support for some USB Bluetooth adaptors in High Sierra!

    Which Bluetooth adaptor do you have? My guess is that it's one using a 'CSR' chipset. It seems that if you have one with a 'Broadcom' chipset (BCM20702?) then it should work. Some people seem to have reported success with a "Trust 18187" USB key.

    Personally I'd contact Apple support - this is classic Apple, but IMO it's just not reasonable to remove support for previously working hardware when you update the OS.

  • It's also not reasonable for them to reject app submissions that are merely bug fixes, but they do that, too…

  • High Sierra was a real slap in the face for hardware developers. Over on the Arduino forums there are tons of problems with it, among them that they broke the drivers for the extremely popular CH340G usb-serial adapter leaving people with those devices unable to use them with their mac for months.

  • Just an update to this - I bought a 'Plugable' BCM20702 dongle, stuck it in a 2009 iMac, and it works fine when the CSR one doesn't... So it looks like that's your solution.

  • Thanks Gordon. I bought a Foktech 6438150 Bluetooth 4.0 USB Dongle Adapter, Broadcom BCM20702 Chipset from Amazon (before reading your post) which arrived recently and tried it out.
    It does not seem to work. It does not even pick up the puck (the previous one detected it but could not connect to it). I will order one of the ones you have tested and listed on the site. Hopefully I will be third time lucky!

  • Yes, that Plugable one is what's in my 2009 iMac right now and it's working fine.

    Before getting a new one it might be worth running through the instructions on flipping the active Bluetooth adaptor over again. I think if you have any previously paired devices then that can stop it choosing the new adaptor.

    I updated the Quick Start page here http://www.espruino.com/Puck.js+Quick+St­art#requirements a few days ago - I bought all of those Bluetooth adaptors to check. While yours isn't on that list, if it's broadcom and set up right I'd be amazed if it isn't going.

  • Thanks Gordon. I will try going through the instructions again with the existing adapter and see if that works. And report back.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

External USB bluetooth (4.0) dongle not connecting to Puck after upgrade to macOS High Sierra but was working fine before that

Posted by Avatar for tanyagupta @tanyagupta